I have an HP Probook 440 G3.

I was previously dual-booting Linux Mint Cinnamon 18.3 with no issues for about a year. Then I started getting the "No boot device found" and other errors. After trying many solutions and finding no solution I decided to wipe my whole hard disk and fresh install Ubuntu.

I freshly installed Ubuntu 18.04 LTS, but I am still facing the errors. My whole filesystem goes into read-only mode after an hour of use and I face this error when I try to reboot the system.

Errors after filesystem becomes read-only -1

Errors after filesystem becomes read-only -2

Sometime I am able to again boot into my OS by doing a force restart using Ctrl + Alt + PrtScr + RSEIUB. Otherwise I have to boot into a LIVE OS and do a fsck on /dev/sda2. Here are the fsck logs https://gist.github.com/nvzard/aecbc8ef62f268a9b413356cb6e4d2da

The fsck fixes the error temporary but I have to do that again when I face the error after 1-2 hour of use.

Here are results of fdisk -l https://gist.github.com/nvzard/1b225b192469efcd353b3385cfa454e9

I even tried the solution suggested in EXT4-fs error after Ubuntu 17.04 upgrade but it didn't seem to work for me.

I also did a smartctl check but got no errors.

Sorry, I don't remember all the solutions I tried because I did try many and I don't remember them.

Please help me solve this problem. I'll post the result of all the commands you want me to try. I have been stuck with it for about a week now and really need my laptop to finish my work. Thanks for your help.

  • Ever since I upgraded to Ubuntu 18.04, I suffer from the same problem; I run for a few weeks (suspend/resume) and suddenly, my root fs becomes RO. Reboot and my ext4 partition has errors. Yet, SMARTD reports that all is fine. I cannot tell if the problem is software or hardware. – Hans Deragon Jul 30 '18 at 11:06
  • Is there any way to get a proper solution/answer to this problem? I wiped my hard drive again and install Ubuntu 18.04 from scratch just to be sure, started facing the same error after a 3 hour of use. Sometimes I get 'Boot Device not Found' error and sometimes it boots the OS but filesystem goes in read-only mode after using for a random amount of time. – Nitanshu Aug 3 '18 at 7:10

Back up your important data now. This may be a hardware error, if not on the disk,maybe on the controller. This sounds like the early stages of a (thermal induced) problem of solder pads cracking on the controller chip. If you can get an external disk enclosure, mount your disk in it, and boot from that, maybe the errors will not occur. If your enclosure works on another laptop, but not yours, the controller may still be at fault, but the fix then is to either replace the motherboard (since the controller is soldered on), or try a really hard re-melt with a heatgun of the chip solder pads.
Do watch your temperatures (lm-sensors package), and consider an external cooler/fan for the laptop. Avoid things which heat the machine up, like maybe streaming video or playing games. I've tried the heatgun on several motherboards, but never got it to work. My problem was an Nvidia controller chip, which was almost as big as the CPU, but didn't even have a heat sink! After three motherboards dying a slow death (first the disk, then months later the usb or wireless), I gave up on that machine.

| improve this answer | |

This might be a weird solution but the service guy from HP visited and cleaned the laptop from inside and removed all the dirt which was somehow blocking the processor fan. I've been using my laptop continuously for more than 24 hours now and I've not faced any single error which I was facing before.

So I guess cleaning the laptop solved the problem for me. Most probably it was due to the fan being blocked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.