0

Ubuntu 18.04 LTS GUI is unusably slow with Matrox G200eR2 (Dell r720xd server).

The gui during install was working smoothly. Also if I boot into safe graphics mode ( https://askubuntu.com/a/901327/299013 ) the GUI just works.

However booting normally the login screen is unusably slow. I get maybe 1 frame every 5 seconds. Then as soon as I log in I get a corrupt picture. Every line in the picture is successively shifted to the right. I can't decipher what is shown.

If I try to run sudo X -configure I get

.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-119-generic x86_64 Ubuntu
Current Operating System: Linux markus-PowerVault-DL2300 4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:39:52 UTC 2018 x86_64 Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=6c37f246-2ca0-4c5d-94c6-ae2a320a0c11 ro quiet splash vt.handoff=1
Build Date: 13 April 2018 08:07:36PM
xorg-server 2:1.19.6-1ubuntu4 (For technical support please see http://www.ubuntu.com/support) Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 28 23:25:09 2018
(EE)
(EE) Backtrace:
(EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4d) [0x558b05e108ad]
(EE) 1: /usr/lib/xorg/Xorg (0x558b05c58000+0x1bc649) [0x558b05e14649] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f1e2d349000+0x12890) [0x7f1e2d35b890] (EE) 3: /usr/lib/xorg/Xorg (0x558b05c58000+0xb2294) [0x558b05d0a294]
(EE) 4: /usr/lib/xorg/Xorg (xf86BusProbe+0x9) [0x558b05ce2229]
(EE) 5: /usr/lib/xorg/Xorg (InitOutput+0x7f1) [0x558b05cf0e51]
(EE) 6: /usr/lib/xorg/Xorg (0x558b05c58000+0x56cd3) [0x558b05caecd3]
(EE) 7: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xe7) [0x7f1e2cf79b97] (EE) 8: /usr/lib/xorg/Xorg (_start+0x2a) [0x558b05c98b8a]
(EE)
(EE) Segmentation fault at address 0x50
(EE)
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting
(EE)
(EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information. (EE)
(EE) Server terminated with error (1). Closing log file.
Aborted

Next I tried to install sudo apt install xserver-xorg-video-mga ( https://askubuntu.com/a/875698/299013 ) but that doesn't exist.

Next I tried to remove all apt remove xserver-xorg-video-\* packages and only apt install xserver-xorg-video-vesa. (https://www.systutorials.com/241655/ubuntus-gui-response-is-very-slow/) But that didn't seem to make any difference.

What can I do to fix the graphics output?

1

Everything "works" if you uncomment WaylandEnable=false in /etc/gdm3/custom.conf.

Source: https://linuxconfig.org/how-to-disable-wayland-and-enable-xorg-display-server-on-ubuntu-18-04-bionic-beaver-linux

I still however get some server-xorg-core crashes.

1

In addition to putting WaylandEnable=false in /etc/gdm3/custom.conf as user643011 said, I was able to make it work by installing Debian 9 package:

wget ftp.debian.org/debian/pool/main/x/xserver-xorg-video-mga/xserver-xorg-video-mga_1.6.5-1_amd64.deb
sudo dpkg -i xserver-xorg-video-mga_1.6.5-1_amd64.deb

and adding blacklist mgag200 to the blacklisted kernel modules in /etc/modprobe.d/blacklist.conf then running update-initramfs -u

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.