1

I have a laptop that has a 500GB HDD, and a 24GB SSD. I currently have ubuntu 16.04 installed on the HDD. I want to do a complete reinstallation of ubuntu, and reinstall a new copy of ubuntu over the old one.

Instead of using a USB flash drive to do this, I want to use my internal SSD. I tried the usual method for using a flash drive, and i got the ISO image onto the SSD, but I cant boot from it, or even see it in the boot menu. I tried changing the boot order, but my BIOS didn't even recognize the SSD.

How can I install ubuntu using an internal SSD?

  • There can be two kinds of problems: 1. Boot from the internal SSD. This depends on the computer's UEFI/BIOS system. Maybe you can find a temporary boot menu. Otherwise you must change the settings to make the computer boot from the SSD; 2. Make the SSD bootable. I do that often (with my SSD) using mkusb. – sudodus Jul 28 '18 at 22:06
  • You can customize grub to boot from an iso and install that way as long as the iso is on a different physical device from where you are installing. If that method will work for you, comment and I'll write an answer. – Organic Marble Jul 28 '18 at 22:14
  • It is also possible, that the computer cannot boot from the internal SSD. What computer is it? Please specify the brand name and model of the computer. – sudodus Jul 28 '18 at 22:15
  • 2
    If you are using an OS that uses grub just add a menuentry to loop mount the ISO on the SSD. Reboot and then install Ubuntu to the HDD. Let me know if you want a full answer. – C.S.Cameron Jul 28 '18 at 22:16
3

Place the Ubuntu ISO at the root of the SSD.

Modify the /boot/grub/grub.cfg as shown:

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry "Ubuntu-18.04 64-bit ISO" {
    set root=(hd0,1)
    set isofile="/ubuntu-18.04-desktop-amd64.iso"
        loopback loop $isofile
        linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile splash --
        initrd (loop)/casper/initrd.lz
}
### END /etc/grub.d/40_custom ###

(hd0,1) assumes root is sda1. If your grub is located on the HDD and not the SSD you will need to give the correct path to the ISO file, set root=(hd?,?).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.