6

My external hard disk 2 TB NAS MyBookLive stopped working so I remove the drive and trying to format it in Ubuntu.

When I format, I get an error message as below

Error Formatting Volume:- Error wiping device. Failed to probe the device 'dev/sdc' (udisks-error-quark,0)

Is my disk dead? If not how to format it please? Many thanks

Assessment says - Disk is OK, but one bad sector.

Update:-

I am not worried to recover the data, as I already have the backup. I only wish to format it and bring the hard disk back to life to use it as another extra backup drive.

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

4
  • 2
    Try to rule out a faulty controller on the MyBookLive. After I swapped the disks on a seemingly dead MyBookLive, I could rescue the data from a seemingly dead and unresponsive drive.
    – emk2203
    Jul 28 '18 at 21:18
  • Can gparted create a new partition table and after that a new partition and file system? If success fine, otherwise try to wipe the first mibibyte with mkusb or to restore the drive to a standard storage device.
    – sudodus
    Jul 28 '18 at 21:27
  • The latest screenshot 'Information about unallocated' looks bad :-( Could you create an MSDOS partition table with gparted? Can you try with mkusb? Anyway, there seems to be either a problem with the partition table or generally to read.
    – sudodus
    Jul 28 '18 at 21:43
  • I think that there is a 'standard' drive with a SATA interface inside the MyBook. Try first in different ways to make it work, for example by connecting it to different computers (with different operating systems). If still no luck and the drive has passed the end of the guarantee, maybe you can open the MyBook Box. It is possible that the SATA drive inside is still good.
    – sudodus
    Jul 29 '18 at 5:13
2

When the S.M.A.R.T. overall assessment is OK (after running a new self-test), the disk is alive.

I think something else is wrong, for example some data in the partition table or a file system, that makes it corrupted.

Maybe you have connected some other USB device, that creates problems for this hard disk drive. Maybe the USB system of the computer has a problem. Maybe the power supply is not quite enough.

The following links can help you analyze the problem, and let us hope, solve the problem. The links may focus on USB pendrives, but the methods and tools can be used for hard disk drives, SSDs and memory cards too (all mass storage devices).

Can't format my usb drive. I have already tried with mkdosfs and gparted

Repair the partition table and file system of a pendrive

4
  • 2
    Please notice that you should create one or more partitions and file systems in the partition(s), so /dev/sdxn should be the target, where x is the drive letter and n is the partition number, for example /dev/sdc1. Or you can let mkusb do the job automatically, if you want one partition and a simple standard FAT32 file system, or for testing. Afterwards you can use gparted and create something more advanced.
    – sudodus
    Jul 28 '18 at 21:12
  • 1
    Many thanks mate would go through it. Even i was not able to create partition, ends in error.
    – Jay
    Jul 28 '18 at 21:23
  • @Jay, What is the result of a new S.M.A.R.T. self-test?
    – sudodus
    Jul 28 '18 at 21:29
  • Do you need data on drive? Or can ypu just nuke with new partition table?
    – fleamour
    Jul 28 '18 at 23:59
2

In similar cases, I've resolved the issue by reformatting in Windows. When a Mac cannot format, sometimes Windows can. When Windows cannot, sometimes Ubuntu can. Also try another partition manager (in Windows) like Aomei or EaseUs

1
  • Had a windows VM running when I read this, so connected the external HDD to the VM and windows mounted it fine, then connected it back to the host and it looked to be working fine, but now under Disks utility I could check/repair the filesystem sucessfully. However this did not work the same for my ext4 formatted disk. Dec 13 '20 at 0:52
1

You can try check hard disk for Bad Sectors by command-line in Ubuntu.

Step 1: First, let’s use the fdisk command to find out the hard disk partitions status.

sudo fdisk -l

Step 2: Next, let’s find if there are any Bad Sectors on the hard disk. We shall use badblocks command. Make sure to enter your hard disk info instead of /dev/sda in below command. My test PC has /dev/sda for the hard disk. This command will scan for bad blocks in the hard disk and then export the result to the file badsectors.txt in the ‘scan_result’ directory.

sudo badblocks -v /dev/sda > /scan_result/badsectors.txt

Step 3: Finally we shall use fsck command to tell Ubuntu not to use the bad sectors mentioned in the badsectors.txt file. That way life of the hard disk is increased a bit until you get a new one for replacement.

sudo fsck -l /scan_result/badsectors.txt /dev/sda

After that you can try format again.

Source: Check hard disk for Bad Sectors by command-line in Ubuntu - fosslinux

2
  • 1
    Thanks mate. fdisk -l is not detecting the drive at all. I have attached the screenshot
    – Jay
    Jul 28 '18 at 21:32
  • Step2 is running for the past 4 days for 2 TB disk, is it normal?
    – Jay
    Aug 3 '18 at 6:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.