0

I'm new here.

I have a problem with my system. I instaled Ubuntu 18.04 as the only OS on my HP Stream 14-cb112dx. I am aware that I must turn off secure boot to get some of the drivers to work such as wifi.

My problem is that whenever I put my system on suspend, lid closed or button press, it wakes up to a CMOS checksum error and has to reset the BIOS which means that secure boot is enabled again.

How do I fix the checksum problem?

  • Hi Gigases - the CMOS error is not something I've seen before but there have been a few problems with Suspend in 18.04. Take a look here: askubuntu.com/questions/1029474/… - I've put an answer with some steps for troubleshooting - I think the nVidia is not relevant but check if it's an s2idle problem with cat /sys/power/mem_sleep and check that it says s2idle [deep] with the square brackets around deep and not s2idle. It's definitely worth trying a 4.14 kernel just to be sure it's not the 4.15 kernel causing it. – pHeLiOn Aug 7 '18 at 15:26
  • I searched for HP Stream 14-cb112dx to see what CPU it uses and whether it's just Intel graphics, but couldn't find the specs because there are many different variations with different product numbers - would be much more helpful if you could supply CPU and graphics info - the code number cb112dx doesn't help ;) – pHeLiOn Aug 7 '18 at 15:30
  • It is an Intel Celeron N4000 CPU @ 1.10GHz x2 with Intel UHD Graphics 600 – Gigases Aug 8 '18 at 16:24
0

I have a HP Stream 14 laptop running Ubuntu 18.04 that also had the CMOS Reset (502) Checksum error. The way I fixed this was by using a newer kernel than that which Ubuntu 18.04 ships, specifically a version above 4.19. My Ubuntu shipped with 4.15.0-42-generic and this caused the CMOS error.

I used the mainline/upstream kernel 4.19.0-041900-generic, and sleep works without any CMOS errors. You can follow the Ubuntu wiki for instructions: https://wiki.ubuntu.com/Kernel/MainlineBuilds

Another option that worked was to use one of the kernel releases from the Linux Kernel Archives at: https://www.kernel.org/ If you go this route, the only one I tested was 4.20-rc6 (4.20.0-042000), and it worked.

To the best of my knowledge this first method of just using a newer kernel only works with kernel versions 4.19 and above.


This second method worked for me before the newer kernels fixed the CMOS on sleep error. It requires you to compile your own kernel with the fixed DSDT table. The above method works well, but for those who might need something for older kernels I did this second method.

With the 4.18.6 official release I had the CMOS error. What I did to fix the sleep on 4.18.6 was to follow the Arch wiki link below and to edit the DSDT tables using iasl and change two of the RTC values:

   `IO (Decode16,
                    0x0070,             // Range Minimum
                    0x0070,             // Range Maximum
                    0x00,               // Alignment  <-- This one was made 00
                    0x02,               // Length <-- This one was made 02
                    )`

Again, this method worked for me on the 4.18.6 kernel version, I did not test other kernel versions. You can follow the Arch DSDT wiki: https://wiki.archlinux.org/index.php/DSDT Make sure however that you compile it into the kernel, not by the CPIO archive method. I recommend HP Stream 14 users to simply use the first method because it saves space and time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.