3

Blank screen after resume from suspend on

  • HP Elitebook 850 G5
  • Intel HD graphics (no dedicated GPU)
  • Ubuntu 18.04

After powering on the laptop to resume, the screen remains blank although the power, numlock and wifi buttons light up. Symptoms:

  • Numlock LED is unresponsive after being pressed, but fn-lock LED is responsive.
  • Ctrl+Alt+F1 and other TTYs don't work.
  • I'm not sure how to do Alt+SysRq+B on this machine (there is no sysrq button, only print screen as an fn-alternative for right shift...) but I tried many options and it doesn't seem to work.
  • The /var/log/kern.log shows no entry whatsoever between the suspend operation and the next boot (after i forced shutdown by holding the power button since the resume did not work):
    Jul 28 10:54:16 pdiracdelta-laptop kernel: [   59.031360] PM: suspend entry (deep)
    Jul 28 10:58:36 pdiracdelta-laptop kernel: [    0.000000] Linux version 4.15.0-29-generic (buildd@lgw01-amd64-057) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #31-Ubuntu SMP Tue Jul 17 15:39:52 UTC 2018 
    (Ubuntu 4.15.0-29.31-generic 4.15.18)
    

Attempted fixes that did not work:

  • blacklist amdgpu (I don't even have an amd gpu but I'm that hopeless...) <-- this turned out to be the solution
  • add to GRUB: nouveau.modeset=0 (does linux even use Nouveau for Intel HD Graphics?)
  • disable BIOS fastboot and deep sleep

UPDATE:

Even when booting into emergency mode and doing suspend+resume from there, the system is frozen with a black screen. So my guess is that it's got nothing to do with the display drivers.

How do I fix this, or even just debug this issue?

P.S.: For what it's worth: I was using Xubuntu 16.04 on the Elitebook 850 G3 without this issue.

  • 1. Does the computer boot live from a USB boot drive? In that case, how did you create i?. Is there a problem with 'blank screen after resume from suspend' also with the live system? 2. In the installed system: Is this problem only happening after resume from suspend (does the installed system work well otherwise)? – sudodus Jul 29 '18 at 10:09
  • It is not booting from a live USB, however I can try to see if the problem is also present when doing that. This problem indeed only occurs when resuming from suspend. If I poweroff and then poweron, it boots fine. I'll try the LiveUSB thing tomorrow. – PDiracDelta Jul 29 '18 at 14:38
  • Can you work around the problem by going to a [virtual] text screen by ctrl+alt+F2 and going back to the graphical desktop (with ctrl+alt+F1 or ctrl+alt+F7)? – sudodus Jul 29 '18 at 15:39
  • update: I have the same issue using the liveUSB, so it must be a hardware/driver issue, no? Also ctr+alt+f1 and stuff doesn't work. HOWEVER I did manage to do SysRq commands (reboot), so the kernel must somehow be responsive even though nothing is logged in kern.log – PDiracDelta Jul 30 '18 at 16:54
  • 1
    Yes, I think so too, that it is a hardware/driver issue. Unfortunately I have no more idea about it (now). Let us hope that somebody else will chip in with fresh tips. – sudodus Jul 30 '18 at 17:23
3

Solution:

Properly (click) blacklist amdgpu, even if you think you're not using it.

Explanation/story:

I thought I had properly tried the amdgpu blacklist fix, but apparently something went wrong. I didn't bother to double-check, since I didn't have an AMD video card.

However, when running gpu-manager, it said

Is amdgpu blacklisted? no

Is amdgpu loaded? yes

This got me somewhat confused so I get checked lspci output again, and sure enough:

01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Polaris12 (rev c3)

So yeah, I guess my graphics processing is still done by Intel HD Graphics, but the device that actually handles displaying those graphics is apparently made by AMD. This also explains why the issue was still present when booting in emergency mode: you're not loading your video card drivers, but you are using your display controller (and hence also its drivers).

  • +1 Congratulations and thanks for sharing your solution :-) – sudodus Jul 31 '18 at 12:02
  • you're welcome :) thanks for the support! – PDiracDelta Jul 31 '18 at 12:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.