2

After upgrading from 16.04 to 18.04 the Desktop does not display any icons shown on 16.04.

Description:

Now that 18.04 is installed I can access all the desktop saved files in Nautilus. But the physical desktop will not show anything even the trash bin. Although the launch bar is working and I can click left to settings and change the Desktop background, there are no copy, paste & new folder option.

enter image description here

I tried TWEAKS and Dconf Editor (show desktop icons).

$ gsettings get org.gnome.desktop.background show-desktop-icons
true

Yes "ll ~/Desktop" I can see all my desktop files.

gxxx@gxxx-Inspiron-5559:~$ ll ~/Desktop
total 100
drwxr-xr-x  4 gxxx gxxx 81920 Jul 29 11:11  ./
drwxr-xr-x 51 gxxx gxxx  4096 Jul 29 11:08  ../
drwxrwxr-x  2 gxxx gxxx  4096 Jul 28 10:39  Cycli/
drwxr-xr-x  5 gxxx gxxx  4096 Jul 28 12:38 'Desktop folder'/
-rw-rw-r--  1 gxxx gxxx  2826 Jul 28 10:24 'ffmpeg video'

gxxx@gxxx-Inspiron-5559:~$ ll ~/Desktop/"Desktop folder"
total 1550968
drwxr-xr-x 2 gxxx gxxx      4096 Jul 29 11:30  ./
drwxr-xr-x 3 gxxx gxxx      81920 Jul 29 11:35  ../
-rw-rw-r-- 1 gxxx gxxx         42 Mar 22 11:15 'COD COI'
-rw-rw-r-- 1 gxxx gxxx     479510 May 27 17:18 'phonétique  symbole.pdf'
-rw-rw-r-- 1 gxxx gxxx 1587609600 Feb 22 13:59  ubuntu-16.04.3-desktop amd64.iso

My Version of UBUNTU:

LSB Version:    core-9.20170.....
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:        18.04
Codename:       bionic

Name:           GNOME Shell
Class:          N/A
PID:            N/A
Window manager's "showing the desktop" mode: N/A

Thank in advance for your help!

G.

closed as off-topic by pomsky, karel, Zanna, muru, Melebius Aug 8 '18 at 11:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – pomsky, karel, Zanna, muru, Melebius
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I deleted my answer below because you had already tried that. Could you update your question with the output from ll ~/Desktop? – WinEunuuchs2Unix Jul 29 '18 at 17:54
  • Yes you can see them but we cannot. Can you copy the output from your screen and paste it into your question? I'm most interested in the executable bit but there might information of interest to others. – WinEunuuchs2Unix Jul 29 '18 at 18:08
  • No worries. I see the problem now. The ~/Desktop folder doesn't contain any icons. Update your question with the output from ll ~/Desktop/"Desktop folder" – WinEunuuchs2Unix Jul 29 '18 at 18:19
  • Oh that kind of complicated things instead. The contents of "Desktop folder" is no longer needed. I'll undelete and update my answer now. – WinEunuuchs2Unix Jul 29 '18 at 18:57
  • before using ll ~/Desktop should show no x in the first 10 characters. After using every third character should be x? You might need to reboot/relogin after running the command though. – WinEunuuchs2Unix Jul 29 '18 at 19:17
0

Open terminal, run ls to see files. Maybe "cd" then "ls Desktop". Are files there? When in doubt, don't rely on the GUI.

I expect your desktop programs failed to remain coherent because the upgrade skipped a large series of changes. If you had Unity desktop, which is dead now, the upgrade to another desktop framework would not usually be smooth.

I would explore by figuring out what desktop system you are running and 1 make sure all packages for it are installed 2 check if legacy config from old desktop is in way.

I rum xfce desktop, works fine. You will fix once you figure out what desktop you are starting and what it needs. When you log in, do you see a setting symbol where you choose? That's the place to get started

0

Your icons need to be executable

You need to set the execute bit of your icons with:

chmod a+x ~/Desktop

Initial Answer Below

Use this command first:

$ gsettings get org.gnome.desktop.background show-desktop-icons
false

If the returned value is false then set it to true using:

$ gsettings set org.gnome.desktop.background show-desktop-icons true
true

I'm not certain if you've already tried something similar with tweaks. If this doesn't fix the problem, let me know and I'll delete my answer.

  • Thanks! Yes I did and the value is -True – Sardonic Jul 29 '18 at 17:28
0

I have "solved" that problem by reinstalling Ubuntu 18.04 as the problem was persistent!

Not the answer you're looking for? Browse other questions tagged or ask your own question.