2

I set my thunar settings to view as list, show hidden files etc.

Those settings are lost on a reboot.

How do I repair that?

2
  • It looks very strange. Many times you write your question here and on Ubuntu MATE community. Both are Ubuntu, this in not the problem. But why you do not want to use Caja? Just curious. About settings - do you have any problems with permissions? If unsure run sudo chown -R $USER:$USER ~ and test again. – N0rbert Jul 27 '18 at 18:37
  • Thunar has more features, custom actions, etc. – fixit7 Jul 27 '18 at 22:18
3

I have Thunar 1.6.15 installed on a Lubuntu 18.04 system.

Thunar --- View Settings

The image shows the View dropdown with the various options. The Show Hidden Files and View as Detailed List settings behave as expected.

The changes should be reflected in ~/.config/xfce4/xfconf/xfce-perchannel-xml/thunar.xml.

Here are the contents of thunar.xml with the Show Hidden Files and View as Detailed List settings active:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="thunar" version="1.0">
  <property name="last-view" type="string" value="ThunarDetailsView"/>
  <property name="last-icon-view-zoom-level" type="string" value="THUNAR_ZOOM_LEVEL_NORMAL"/>
  <property name="last-window-maximized" type="bool" value="true"/>
  <property name="last-details-view-zoom-level" type="string" value="THUNAR_ZOOM_LEVEL_SMALLER"/>
  <property name="last-details-view-column-widths" type="string" value="50,188,50,50,641,50,50,83,174"/>
  <property name="last-show-hidden" type="bool" value="true"/>
  <property name="last-separator-position" type="int" value="170"/>
  <property name="misc-single-click" type="bool" value="false"/>
</channel>

Here are the contents of thunar.xml with the Show Hidden Files and View as Detailed List settings turned off:

<?xml version="1.0" encoding="UTF-8"?>

<channel name="thunar" version="1.0">
  <property name="last-view" type="string" value="ThunarCompactView"/>
  <property name="last-icon-view-zoom-level" type="string" value="THUNAR_ZOOM_LEVEL_NORMAL"/>
  <property name="last-window-maximized" type="bool" value="true"/>
  <property name="last-details-view-zoom-level" type="string" value="THUNAR_ZOOM_LEVEL_SMALLER"/>
  <property name="last-details-view-column-widths" type="string" value="50,188,50,50,654,50,50,83,174"/>
  <property name="last-show-hidden" type="bool" value="false"/>
  <property name="last-separator-position" type="int" value="170"/>
  <property name="misc-single-click" type="bool" value="false"/>
</channel>

Of note are the values of property name="last-show-hidden" and property name="last-view".

Could it be, though I can't say why, that your ~/.config/xfce4/xfconf/xfce-perchannel-xml/thunar.xml is damaged or that it doesn't have the appropriate permissions or that Thunar cannot, for whatever reason, write changes to this file?

In my case, the permissions look like this:

dkb@dkb:~/.config/xfce4/xfconf/xfce-perchannel-xml$ ls -l
total 12
-rw-r--r-- 1 dkb dkb 847 Jul 28 07:26 thunar.xml
-rw-r--r-- 1 dkb dkb 429 May  9 06:16 xfce4-power-manager.xml
-rw-r--r-- 1 dkb dkb 212 May  9 06:16 xfce4-session.xml
dkb@dkb:~/.config/xfce4/xfconf/xfce-perchannel-xml$ 
3
  • 1
    Good effort to write out details. Matches my dystem – pauljohn32 Jul 28 '18 at 3:22
  • In your question you didn't specify that changes were lost after a reboot. If that is the case, see if askubuntu.com/a/427962/248158 helps. – DK Bose Jul 28 '18 at 16:51
  • 1
    I found the problem. /home/andy/.config/xfce4/xfconf/xfce-perchannel-xml/ was set to root as owner. I changed owner to myself. – fixit7 Jul 28 '18 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.