7

I'm trying to install wine on my operating system:

uname -a
Linux morad-Vostro-1540 4.15.0-22-generic #24-Ubuntu SMP Wed May 16 12:15:17 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

when I execute this command I get the following error:

wine --version

it looks like wine32 is missing, you should install it. as root, please execute "apt-get install wine32" wine-3.0 (Ubuntu 3.0-1ubuntu1)

and when I run this command:

> sudo apt-get install wine32

i get the following issue:

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des informations d'état... Fait Certains paquets ne peuvent être installés. Ceci peut signifier que vous avez demandé l'impossible, ou bien, si vous utilisez la distribution unstable, que certains paquets n'ont pas encore été créés ou ne sont pas sortis d'Incoming. L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites : wine32:i386 : Dépend: libwine:i386 (= 3.0-1ubuntu1) mais ne sera pas installé E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

update:

Why do I get this error when I try to execute, this command:

sudo apt-get update

> Atteint:1 http://archive.ubuntu.com/ubuntu bionic InRelease           
> Atteint:2 http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic
> InRelease      Atteint:3 http://dl.winehq.org/wine-builds/ubuntu
> xenial InRelease                Ign:4 http://archive.canonical.com
> precise InRelease                              Réception de:5
> http://archive.canonical.com precise Release [8 180 B]            
> Atteint:6 http://ppa.launchpad.net/linuxuprising/java/ubuntu bionic
> InRelease     Réception de:7 http://archive.canonical.com precise
> Release.gpg [181 B]           Ign:8
> http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic InRelease  
> Ign:9 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu bionic InRelease
> Atteint:10 http://ppa.launchpad.net/webupd8team/y-ppa-manager/ubuntu
> bionic InRelease Err:11
> http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release    
> 404  Not Found [IP : 91.189.95.83 80] Ign:7
> http://archive.canonical.com precise Release.gpg                      
> Err:12 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu bionic Release 
> 404  Not Found [IP : 91.189.95.83 80] Lecture des listes de paquets...
> Fait                            E: Le dépôt
> http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release n'a
> pas de fichier Release. N: Les mises à jour depuis un tel dépôt ne
> peuvent s'effectuer de manière sécurisée, et sont donc désactivées par
> défaut N: Voir les pages de manuel d'apt-secure(8) pour la création
> des dépôts et les détails de configuration d'un utilisateur. W: Erreur
> de GPG : http://archive.canonical.com precise Release : Les signatures
> suivantes n'ont pas pu être vérifiées car la clé publique n'est pas
> disponible : NO_PUBKEY 40976EAF437D05B5 E: Le dépôt
> http://archive.canonical.com precise Release n'est pas signé. N: Les
> mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière
> sécurisée, et sont donc désactivées par défaut N: Voir les pages de
> manuel d'apt-secure(8) pour la création des dépôts et les détails de
> configuration d'un utilisateur. E: Le dépôt
> http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu bionic Release n'a pas
> de fichier Release. N: Les mises à jour depuis un tel dépôt ne peuvent
> s'effectuer de manière sécurisée, et sont donc désactivées par défaut
> N: Voir les pages de manuel d'apt-secure(8) pour la création des
> dépôts et les détails de configuration d'un utilisateur.
> morad@morad-Vostro-1540:~$ sudo apt-get install wine32 Lecture des
> listes de paquets... Fait Construction de l'arbre des dépendances     
> Lecture des informations d'état... Fait Certains paquets ne peuvent
> être installés. Ceci peut signifier que vous avez demandé
> l'impossible, ou bien, si vous utilisez la distribution unstable, que
> certains paquets n'ont pas encore été créés ou ne sont pas sortis
> d'Incoming. L'information suivante devrait vous aider à résoudre la
> situation : 
> 
> Les paquets suivants contiennent des dépendances non satisfaites : 
> wine32:i386 : Dépend: libwine:i386 (= 3.0-1ubuntu1) mais ne sera pas
> installé E: Impossible de corriger les problèmes, des paquets
> défectueux sont en mode « garder en l'état ».
2
  • It's hard to help because the error message is not in English. – SurvivalMachine Jul 27 '18 at 18:25
  • 1
    I think you need to run sudo dpkg --add-architecture i386 before you try installing wine32. – Terrance Jul 27 '18 at 20:30
3

I installed wine yesterday in Lubuntu 18.04(based on Ubuntu).

You simple need to go to the synaptic package manager, and search the package named wine-stable(actually i have the 3.0.1 version).

You only need to install that package, and the dependencies will install with it.

After you have done that, you should open a terminal console, and type "winecfg"

Then you have Wine installed on you Ubuntu. If you now want to install something(an .exe for example) you should use the cd command in the console and go to the folder containing the exe. Then you should type on the console: " wine installer.exe" where installer.exe is the name of the file that you want to install.

2
  • Agreed. If 18.04 users would just do this it seems half of ask ubuntu traffic would vanish. – Organic Marble Apr 28 '20 at 11:41
  • The error in English is: "it looks like wine32 is missing, you should install it. multiarch needs to be enabled first. as root, please execute "dpkg --add-architecture i386 && apt-get update && apt-get install wine32" No, your "fix" and these instructions don't work. When this error occurs after wine-stable has been installed, it's because Ubuntu has been upgraded, for example from Xenial to Bionic, and something remains from the former installation. The only fix is to reinstall Ubuntu, keeping no configuration from the previous version, and only then, "simply" install wine. – Nicolay77 May 10 '20 at 3:38
1

It is unclear why you can't install wine32 package. But for sure let's (re)-add all necessary repositories

sudo add-apt-repository main
sudo add-apt-repository universe
sudo add-apt-repository multiverse

update package cache and upgrade all packages to 18.04.1 LTS

sudo apt-get update
sudo apt-get dist-upgrade

and then install wine32 package

sudo apt-get install wine32
3
  • thank you so much, I executed the instruction which you give me, but I can't solve my problem, here's what I got: sudo apt-get install wine32 [sudo] Mot de passe de morad : Lecture des listes de paquets... Fait Construction de l'arbre des dépendances ... L'information suivante devrait vous aider à résoudre la situation : Les paquets suivants contiennent des dépendances non satisfaites : wine32:i386 : Dépend: libwine:i386 (= 3.0-1ubuntu1) mais ne sera pas installé E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ». – moradov Jul 28 '18 at 0:14
  • sorry, this message is in french, i asked a related question before here, but i don't solve my problem – moradov Jul 28 '18 at 0:22
  • dist-upgrade is irrelevant here – chefarov Mar 9 '19 at 13:30
0

Please try using aptitude, which do a better work with wrong dependencies. sudo aptitude install wine-stable wine32

The aptitude command will ask you whether you could want to remove old or broken dependencies and fix them. Hope it helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.