There is a computer on my network running Windows 7 Professional with a bunch of shared folders and printers available on the default WORKGROUP domain. There is no password for any of these shares and they can be happily accessed from Windows on any other computer on the network. (And all the Windows computers can access Ubuntu's Samba shares).

If I use the Network place in Nautilus, the computer itself is visible under smb://workgroup/. However, when I try to mount that, Nautilus asks me for a password! With no other option, I entered the username and password for the one user on the machine. It tried to do something for a second then asked again (ad infinitum).

Trying to add a printer with CUPS is equally broken. Its various interfaces have given me “Unable to connect to CIFS host” and “NT_STATUS_INVALID_PARAMETER,” but I'm not sure if it's the same problem. If we can figure out the file shares first, maybe that will explain itself.

Samba itself should be almost pristine. I have not touched any configuration files; just added some shares through the Folder Sharing options in Nautilus (nautilus-share).

Any idea what's going on here? :)

2 Answers 2


Last time I checked (some months ago), I explicitly had to add a permission for "Guest" to the Windows 7 share (Advanced Sharing > Permissions) to allow password-free connections. "Everyone" alone didn't work for whatever reason. Maybe this has changed in the meantime, but it's worth a try.


The problem here is most likely the fact that samba is not perfect and sometimes has problems with newer versions of windows.

Samba actually has to play a kind of catch up game with windows, so sometimes thinks break between windows versions. If you need to configure samba (it might not fix the problem NB) try GADMIN-Samba in the software center.

You could also try tweaking the sharing options on windows 7, but in my experience vista and seven tend not to work too well with Samba.

  • I was afraid of that, but that's a nice answer to have. Good to know it isn't just me :) Nov 4, 2010 at 3:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .