26

Is there any gsettings schema to select "Never" on

system settings->software and updates->updates->automatically check for updates

Any other command line option to disable automatic updates is right for me.

Thank You

3
28

According to this post

Disable apt-daily.service:

systemctl stop apt-daily.timer
systemctl disable apt-daily.timer
systemctl disable apt-daily.service
systemctl stop apt-daily-upgrade.timer
systemctl disable apt-daily-upgrade.timer
systemctl disable apt-daily-upgrade.service

Or

systemctl disable --now apt-daily{,-upgrade}.{timer,service}
3
  • 3
    The other command seems to work... – Aleksandar Pavić Apr 22 '19 at 7:40
  • 1
    What "other command?" – mr.zog Oct 24 '19 at 16:01
  • 1
    @mr.zog I'm guessing systemctl disable --now apt-daily{,-upgrade}.{timer,service} @abu_bua @AleksandarPavić please confirm. – Chaitanya Bapat Apr 27 '20 at 17:14
9

Thanks to suggestions from Norbert and doug I came up with this solution:

sudo sed -i 's/APT::Periodic::Update-Package-Lists "1"/APT::Periodic::Update-Package-Lists "0"/' /etc/apt/apt.conf.d/20auto-upgrades
2
  • Result for me on 18.04 : "can't read /etc/apt/apt.conf.d/20auto-upgrades: No such file or directory", can I simply create the file? Or does it exist under another file name? – Meloman Dec 16 '20 at 9:06
  • that's weird.. I have couple of machines with Ubuntu 18.04 and all of them have that file..you'd better open a new question on this.. – rok Dec 16 '20 at 9:18
6

No, there is no gsetting for this. In 16.04 those relevant options are set in the /etc/apt/apt.conf.d/10periodic file

Obviously the easiest way to alter is thru Software & Updates > Updates which edits that file if you change from default.

You can edit that file manually if desired or fashion some command to set the option(s) to false ("0"

Edit /etc/apt/apt.conf.d/20auto-upgrades to disable automatic updates from the command line:

$ sudo nano /etc/apt/apt.conf.d/20auto-upgrades

Once you have the file opened, switch off the Update-Package-Lists directive from 1 to 0 as shown below:

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Unattended-Upgrade "1";
1
  • 1
    This file doesn't exist. – Cerin Dec 3 '20 at 21:30
3
sudo dpkg-reconfigure unattended-upgrades

worked for me with Ubuntu 16.04 server. It created the following output:

Replacing config file /etc/apt/apt.conf.d/20auto-upgrades with new version

After the reconfig (disable auto-updates), 20auto-upgrades contained this:

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Unattended-Upgrade "0";
1
  • Could you improve your answer (editing it) specifying in which version of Ubuntu you tested this solution? In this way, who reach this topic may use one solution or the other according to the Ubuntu version in own machine. – Lorenz Keel Aug 27 '20 at 7:40
1

In Ubuntu 18.04 (LUbuntu) I had no easy way to do it, but to symlink to true:

mv /usr/bin/update-manager /usr/bin/update-manager.bak # if needed
ln -s /bin/true /usr/bin/update-manager

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.