1

This question already has an answer here:

My problem is that I can't connect to the internet on my HP envy laptop, with Ubuntu 16.04 installed on it in dualboot with windows 10. UEFI secure boot is disabled.

bcmwl-kernel-source is already installed.
The same for broadcom-sta-*.

I am an inexperienced user of Ubuntu. But, I can tell that Wifi worked for a while and then, it doesn't anymore. I have looked for a solution on the internet but I couldn't find (or understand ?) how to solve my problem.

I have no internet connection from this computer.

The result of lspci -nn | grep -i net gives :

01:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev01)

The result of rfkill list gives :

0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no

Then, ifconfig -a:

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
Packets reçus:26316 erreurs:0 overruns:0 fram:0
TX packets:26316 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:1954296 (1.9 MB) Octets transmis:1954296 (1.9 MB)

EDIT : lspci -knn | grep Net -A3 gives :

01:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev01)
Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n [103c:804a]
02:00.0 Unassigned class[ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader [10ec:522a] (rev01)
Subsystem: Hewlett-Packard Company RTS22A PCI Express Card Reader [103c:80df]

EDIT : uname -r

4.15.0-29-generic

Tell me if you need more info about this. Thanks in advance for your answers.

Remi

marked as duplicate by Pilot6, karel, Kevin Bowen, Community Jul 30 '18 at 6:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 Jul 27 '18 at 9:26
  • Also: uname -r We are guessing it is 4.15.0-29. – chili555 Jul 27 '18 at 14:36
  • Did you follow the steps in askubuntu.com/questions/55868/… making sure that the currently installed drivers are purged to avoid overlapping conflicts. – Luis Alvarado Jul 29 '18 at 12:40
  • You are right, I think the problem is very similar but the bdcom-0ubuntu1~1.2 didn't work for me... I installed bdcom-0ubuntu4 instead and it worked. – Rem Cai Jul 30 '18 at 6:23
0

wget http://mirrors.kernel.org/ubuntu/pool/restricted/b/bcmwl/bcmwl- kernel-source_6.30.223.271+bdcom-0ubuntu4_amd64.deb

sudo dpkg -i bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu4_amd64.deb

This actually works for Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365]

Caution: This firmware does not allow hotspot creation

  • Thank you for this answer !! This version worked for me ! – Rem Cai Jul 30 '18 at 6:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.