30

I understand that the first point release of Ubuntu 18.04, namely 18.04.1 is now available and that my system should now offer it as an update.

My current OS version is 16.04.5 LTS. In System Settings/Software and Updates I have set 'Notify me of a new Ubuntu version' to 'For long term support versions'. I have tried both the main server and the server for United Kingdom, neither offers an update when Software Updater is clicked or via the Ubuntu Software icon.

Can anyone please tell me why I don't get the option of updating to 18.04?

Edit:

I don't remember the details exactly, but I think that my last LTS point release update was offered automatically a lot sooner after the published release date than where we are now with 18.04.1.

Edit 10th August

It appears that there has been some problem with the update process and that it should be fixed next week, see:

Ubuntu change log

Edit 14th August 18.04.1 LTS now available from UK server,

  • 2
    be careful about what you wish for... when it's ready you'll be informed. From what I read, some of the features of the new version will be drip fed into 16.04.nn and on that basis, I'm content to carry on with v16LTS given the continuing problems with 18. – User24601 Jul 27 '18 at 7:49
  • 3
    Yes the upgrade from 16.04 LTS to 18.04 LTS does not occur until the .1 release has been out, but the usual procedure is the 'taps' are turned on a few days after the .1 release. Currently we're only hours after it, and not 'days'. – guiverc Jul 27 '18 at 8:07
  • 5
    @Graham what are the continuing problems with 18.04? (I haven't been paying attention, being content with 16.04.) – RonJohn Jul 27 '18 at 14:20
  • 5
    @Graham Name the two most significant in your opinion; dodging the question doesn't support your argument. – user854229 Jul 27 '18 at 19:15
  • 3
    @Rogem I'm also curious about the issues mentioned by Graham, but the official list is here: wiki.ubuntu.com/BionicBeaver/ReleaseNotes#Known_issues – Daniel Serodio Jul 31 '18 at 18:32
23

The upgrade from 16.04 LTS to 18.04 LTS does not occur until the .1 release has been out. The usual procedure is the 'taps' are turned on a few days after the .1 release. Currently we're only hours after the release, not 'days', so the update will not be offered quite yet.

It's mentioned in the release notes:

"Users of Ubuntu 16.04 will soon be offered an automatic upgrade to 18.04.1 via Update Manager."

-- update 2018-08-08 ~04:30 UST/UTC

It may soon be available; if this is the 'critical' bug holding up release (https://bugs.launchpad.net/ubuntu/+source/gnome-menus/+bug/1766890) - it only impacts 16.04 LTS -> 18.04 LTS upgrades. 18.04.1 is stable; it's the upgrade-path that is turned-off..

-- update 2018-08-10 ~10:10 UST/UTC

https://lists.ubuntu.com/archives/ubuntu-release/2018-August/004556.html

"We are working on resolving bug http://launchpad.net/bugs/1766890 which results in a bad upgrade experience when people upgrade to Ubuntu 18.04. There is a new version of the dist-upgrader in -proposed and we will be testing it the next couple of days and plan on updating meta-release-lts at the beginning of next week."

| improve this answer | |
  • 2
    It's now the 31st and at least on my server install askubuntu.com/questions/1061111/… this has not happened, why is there no release date / schedule for when the LTS to LTS upgrades go live? Rather than a vague and inscrutable "a few days" or "sometime". Many of us would like to plan LTS to LTS upgrades! – Matt Bashton Jul 31 '18 at 15:37
  • 3
    @MattBashton You can always do it yourself before it's official by sudo do-release-upgrade -d – Organic Marble Jul 31 '18 at 23:02
  • 11
    August 4, 9+ days after the .1 release, still getting "no new release found." Time to redefine "a few" ? – Steve Valliere Aug 4 '18 at 11:50
  • 5
    I noticed today (5 aug 2018): "new release '18.04.1 LTS' available" but only when passing the "--dev" flag! So it seems there's really a problem as this version shouldn't be considered as a dev version. – COil Aug 5 '18 at 7:56
  • 4
    It may soon be available; if this is the 'critical' bug holding up release (bugs.launchpad.net/ubuntu/+source/gnome-menus/+bug/1766890) - it only impacts 16.04 LTS -> 18.04 LTS upgrades. 18.04.1 is stable; it's the upgrade-path that is turned-off... – guiverc Aug 8 '18 at 4:32
2

For anyone still receiving the "No release found" error several days after 18.04.1, this process worked for me to upgrade from 16.04.5 to 18.04.1:

Software & Updates > Updates > Notify me of a new Ubuntu Version > Select "For Any New Version" > Open Software Updater

For some reason, "For long-term support versions" was not notifying me about 18.04.1 LTS.

Once I changed it to "For any new version" I was immediately prompted to upgrade to 18.04.1. The upgrade has run without issue.

Mahalo to deadflowr for originally suggesting this fix here: https://ubuntuforums.org/showthread.php?t=2397703

| improve this answer | |
  • 1
    If that doesn't work, this command in terminal did the work for me: /usr/lib/ubuntu-release-upgrader/check-new-release-gtk – chomp Aug 20 '18 at 14:19
0

Guiverc, you seem to have the best fix on this. You indicated that forcing the upgrade (-d) worked well for you. Does this still work unattended, or will a relative newbie like me get into difficulties? Is the "official" release likely to be within an additional day or two so that we should be patient? Do you have any sense what kinds of problems are holding up the official release?

Addendum: I run Ubuntu from a VBox virtual machine. So I cloned my 16.04 version and ran sudo do-release-upgrade -d.

  • a) The update worked and completed without hitch and without any need for user intervention. All of my most important apps seem to work fine.
  • b) There were a number of warnings about configuration files that were missing or directories that couldn't be deleted, but these issues seem to have been dealt with later in the update.
  • c) One issue should be noted. The update program warned me that the xenial R source entry in my /etc/apt/sources file had been commented out, but noted that I could reactivate it after completing the update. Unfortunately there doesn't seem yet to be a Ubuntu R bionic repository. Fortunately both R and RStudio appear to be updated correctly within the apps, but I suspect that I won't be told of updates of R by the Ubuntu Update app. In sum, it seems that using the -d option for the Ubuntu update from 16.04 to 18.04 works well. But NO GUARANTEES. Larry Hunsicker
| improve this answer | |
  • 3
    The way we use our own machines differs, and I like your reasoned approach (particularly test upgrade). I know nothing about R but you may be right in that you may not get updates going forward (unless the app updates itself completely free of ubuntu, which may create issues in time anyway). do-release-upgrade is supposed to remove xenial sources (thru comment). The "-d" is always there, but there is some reason that Canonical have not made the decision to switch-on-16.04-updates, some reason they still feel staying with 16.04.5 currently is more stable; we just don't know what that is. – guiverc Aug 4 '18 at 22:37
  • The official CRAN repository has R 3.5 for Bionic have a look here cloud.r-project.org/bin/linux/ubuntu simply adjust your sources list to look at bionic-cran35/ post install! – Matt Bashton Aug 6 '18 at 10:37
  • i don't know if you watch this - but i've added comments to my answer with more info... & now an ETA has appeared – guiverc Aug 10 '18 at 9:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.