0

I am a new Ubuntu user and I've just started with a fresh install running version Ubuntu 18.04.1. I can't seem to get Openpht to install. Every time I try I just get this error:

(Reading database ... 266350 files and directories currently installed.)
Preparing to unpack .../openpht_1.8.0.148-573b6d73-xenial_amd64.deb ...
Unpacking openpht (1.8.0.148+573b6d73~xenial) over (1.8.0.148+573b6d73~xenial) ...
dpkg: dependency problems prevent configuration of openpht:
 openpht depends on libboost-system1.58.0; however:
  Package libboost-system1.58.0 is not installed.
 openpht depends on libboost-thread1.58.0; however:
  Package libboost-thread1.58.0 is not installed.
 openpht depends on libglew1.13 (>= 1.12.0); however:
  Package libglew1.13 is not installed.
 openpht depends on libmicrohttpd10 (>= 0.9.20); however:
  Package libmicrohttpd10 is not installed.
 openpht depends on libpng12-0 (>= 1.2.13-4); however:
  Package libpng12-0 is not installed.
 openpht depends on libva-x11-1 (>= 1.0.3); however:
  Package libva-x11-1 is not installed.
 openpht depends on libva1 (>= 1.2.0); however:
  Package libva1 is not installed.
 openpht depends on libcec2 | libcec3; however:
  Package libcec2 is not installed.
  Package libcec3 is not installed.

dpkg: error processing package openpht (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
 openpht
  • 1
    Welcome to Ask Ubuntu. Your picture is of text; so please copy & paste it into your question (it's easier to read, and I can copy the packages & look for you - I can't & won't risk typos by trying to perfectly type from a picture). Also stating your version of Ubuntu is helpful (I could guess from packages, again if I could copy & paste packages if it'd been text; bionic?) – guiverc Jul 27 '18 at 0:15
  • I've changed it thanks in advance for your help – Ben Ruckman Jul 27 '18 at 1:17
  • You are running Ubuntu 18.04 (Bionic) you've now confirmed, but are trying to load a package intended for Xenial (16.04). As a result it wants libraries for xenial (eg. picking one packages.ubuntu.com/…) where you'll note it's available for 16.04 LTS. Two years have passed between 16.04 (2016.April) & 18.04 (2018.April release) which means API/ABI changes which is why packages have rules to prevent breakage (crashes etc). As a newbie you should stick to programs for your release (and avoid dep-hell) – guiverc Jul 27 '18 at 1:30
  • Bionic (18.04) uses the 1.62 (not 1.58) version of the package I picked (packages.ubuntu.com/…) . If you add (quick dirty fix) the repo needed to solve that issue, it'll cause a lot more .. which is why its commonly called dependency-hell (a name given by new-users). The new [ubuntu] user fix is to find a 18.04/Bionic source of whatever program you want that will install and run in Ubuntu 18.04. – guiverc Jul 27 '18 at 1:36
  • I'm not going to look at each package; to see if it clashes with others, and can be freely installed in your 18.04 system; you can if you like; but if you do your homework you can avoid dep-hell by allowing only certain packages; but this is not for 'new-users' in my opinion. I also don't know what openpht does which makes it harder for me... – guiverc Jul 27 '18 at 1:42
0

The only way is use the AppImage version of the latest OpenPHT.

Just download the lastest .AppImage file from here:

https://github.com/DEAKSoftware/OpenPHT-AppImage/releases

Then make it executable and run the AppImage file. Just it!

Works on 14.04 and above!

18.04 works like a charm!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.