1

I have Windows 10 installed on my system, and need to install Ubuntu 18.04 as the second OS. (dual boot)

I created a bootable usb, and trying to install Ubuntu from it. However when I select the install or try Ubuntu options, I get a black screen only.

I tried nomodeset setting but nothing changes. (both with and without quiet splash option)

What do you suggest me to try?

I am using a MSI GE63 8RF notebook with NVIDIA GTX1070, Intel I7-8750H.

edit: I added checksum results for the ISO file.

checksum

  • I suspect that there is a problem with the built-in linux driver for the NVIDIA GTX1070 graphics card. Please try with the boot option nomodeset. It should give you some basic but working graphics. Later on, in the installed system, you should also use nomodeset and then maybe try to install an nvidia proprietary driver to get the full power of the graphics card. – sudodus Jul 26 '18 at 21:40
  • @sudodus as I mentioned in my post, I tried nomodeset. do you have any other boot option suggestions that might help? – Amadeus Bachmann Jul 26 '18 at 21:41
  • Sorry, I was reading your question too quickly. I will try to find some other tip (or link) for you. – sudodus Jul 26 '18 at 21:45
  • 1. Try with the brand new (and improved) first point release, the iso file ubuntu-18.04.1-desktop-amd64.iso; 2. See this link, that might add some tips, You can also search AskUbuntu or the internet with the search phrase (without quotes) 'nvidia 1070 graphics boot option' or something similar (that's how I found the link supplied). Good luck :-) – sudodus Jul 26 '18 at 21:59
  • @karel I have already seen that link before opening this topic. That did not help unfortunately. – Amadeus Bachmann Jul 27 '18 at 5:30
0

I had the same problem on a similar laptop (MSI GE73 8RF).

Quick Solution:
In this particular case, system should be able to boot with kernel parameter acpi=off.

Proper Solution:
If the quick solution works, update the BIOS: Bios update for MSI GE63 8RF
The zip file contains a guide (pdf) on how to update the BIOS.


For me, after BIOS update, mouse and keyboard did not work on live booted Ubuntu
Solution is to use kernel parameter iommu=soft.

Once Ubuntu is installed, the kernel parameter is not required.

-1

My best guess based on the information you have provided us is that you either downloaded the wrong version of Ubuntu (like an ARM version instead of AM64), or there was something wrong with your flashing process. What program did you use to flash the USB stick?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.