4

Today somehow my Super key is disabled. I can't use it, neither the laptop keyboard nor external keyboard. When I press the Super key, it does not send the Super key signal to ubuntu (18.04 LTS). Somehow it changed.

I checked the Super key by xev command. Here is the output:

KeyRelease event, serial 37, synthetic NO, window 0x3400001,
root 0x176, subw 0x0, time 4735544, (559,365), root:(661,519),
state 0x2010, keycode 133 (keysym 0xfe08, ISO_Next_Group), same_screen YES,
XLookupString gives 0 bytes: 
XFilterEvent returns: False

I have some key binding with Super key. I use keyboard shortcut for changing writing language, opening dash, changing window/application etc.

Please tell me how to enable the key.

Update:

The problem seems to occur after every shutdown. There might be an application which is overriding the key. Instead of running the command every time, I have figured out another simple way. See the updated answer.

2
  • Requesting a moderator/Admin to close this question. Jul 26, 2018 at 18:16
  • 1
    nobody has to "close" your question, self-answering your question is absolutely fine (and encouraged) here. To indicate that you already have a solution and no longer looking for a solution, you may may "accept" your answer (by clicking on the tick mark (✓) next to it). But to accept your own answer you'll have to wait for 2 days (since the question was posted).
    – pomsky
    Jul 26, 2018 at 19:37

2 Answers 2

5

I've looked into this thread and ran

xmodmap -e "keycode 133 = Super_L"

which solved my problem.

Update:

The problem seems to occur after every restart (shutdown). I couldn't figure out why this happens. To prevent this, I added the following command in startup application:

xmodmap -e "keycode 133 = Super_L"

Apparently, this is the only known solution to me.

2
  • You can mark your own answer as accepted.
    – TRiG
    Jul 26, 2018 at 18:19
  • 1
    @TRiG, Sorry, Askubuntu won't let me accept it before two days. I'll do it later. Jul 26, 2018 at 18:36
1

For my case I was using the Alt key and 12 on HP Victus. But I clicked on Fn+F12 which locks the Windows/Super key since it was a gaming laptop which has such features enabled, i.e. you can lock the Windows/Super key to avoid accidental clicks on it. Clicking Fn+F12 unlocked it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .