0

This worked on an Ubuntu 14.04 machine. I just switched to Ubuntu 18.04. This isn't working.

It's all updated.

I plugged in an external drive. I went and looked at the drive through the gui, if that matters. It does matter on an Ubuntu live CD vm apparently. So I did that.

On the 14 machine, I had to do this initially with an external drive so I had permissions on it. Maybe I also went through the gui properties permissions to set that to read/write. It's been a while.

chown -R myUbuntu18account: /media/myubuntu18account/longdrivenumber

I thought that solved it in the past, at least on Ubuntu 14.

I tried copying -- both through the gui and from terminal -- but when I copy folders/files off the external drive, I only get some of them. The external drive folder might be 20GB. I get 500MB worth of files. I checked permisisons on the files in the folder and it looks like most don't have my account listed with read/write permissions.

Am I missing or forgetting something? I'm pretty sure on Ubuntu 14 I just plugged the drive in, got the long, unique number off the drive's properties, and did a "chown -R account: /media/account/longnumber" and I was good to go for working with the external drive, meaning that I could just copy to and from it with ctrl-c and ctrl-v.

Help!!! Maybe it's something with setting permissions specifically, chmod xyz stuff, but I don't remember having to do that. I'm looking at notes and don't see anything like that before. Plus, I popped drive in and out often enough I'd remember.

  • Please edit the output of ls -l /media/$USER with the external drive attached and mounted into your post. Thank you for helping us help you! – Elder Geek Jul 26 '18 at 16:20
  • 1
    What is the filesystem on your external drive? – danzel Jul 26 '18 at 16:29
  • I would have formatted the external drive as gpt and ext4. – ubuntuthinking23523 Jul 26 '18 at 18:34
  • ls -l /media/$USER gives me.... (Fine, a new post since I can't hit Enter here...) – ubuntuthinking23523 Jul 26 '18 at 18:39
  • drwxrwxrwx 1 accountname accountname 4096 Jun 6 16:01 longnumberforexternaldrive – ubuntuthinking23523 Jul 26 '18 at 18:40
0

Maybe it's this.
No progress bar when copying files on Ubuntu 17.10 There's a circle instead of a progress bar now. If I click on that, I do get the progress bar.

While copying, I got a permissions box pop up. Last week the copying eventually errored out. Today it appears to be moving. No other changes made to permissions. I did restart the machine, but I tried that last week too.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.