15

Dummy output is showing in Settings -> Sound in Ubuntu 18.04.

enter image description here Dummy Output

I tried:

sudo alsa force-reload

It does nothing. I am not sure what else to try.

$ lsb_release -a 
No LSB modules are available. 
Distributor ID: Ubuntu 
Description: Ubuntu 18.04 LTS 
Release: 18.04 
Codename: bionic 

$ lsmod | grep snd_hda_intel
snd_hda_intel          40960  3
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_pcm                98304  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd                    81920  18 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm

$ lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-H HD Audio [8086:a170] (rev 31)
     Subsystem: Micro-Star International Co., Ltd. [MSI] Sunrise Point-H HD Audio [1462:fa15]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel model=auto

Tried also:

$ pacmd list-cards
0 card(s) available.
$ aplay -l
aplay: device_list:270: no soundcards found...

I will further note: When I use USB sound card it does not work on boot it does not show at all. When I disconnect it and connect it again it starts working. How can I establish which application captures the sound cards?

8

Just wanted to add to this, I followed similar instructions to have sound work briefly after a reboot with a dell XPS 13 running Ubuntu cosmic (18.10). Switching between 'auto' and 'generic' didn't change much

sudo alsa force-reload

worked for me.

| improve this answer | |
  • Previously I tried this and it did now work. However I tried now and it did. Will see after reboot. – berduchwal Jan 4 '19 at 9:51
  • 1
    It only worked this time. After reboot I am back to Dummy Output. – berduchwal Jan 8 '19 at 21:37
  • For me it show that none to reload? – user40491 Apr 23 at 18:56
3

Dummy Output

I realize this is an older question but following the suggested fixes did not work for me. I was running 16.04 just fine but did a fresh install of 18.04 and lost audio. I further upgraded to 18.10 and still did not have audio.

Profile

After a bit of searching, I found help on this forum. When running pacmd list-cards I noticed that although it saw my audio card, the active profile was off. To fix this, I ran:

pacmd set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo

As soon as I did this, my Sound Preferences showed Built-in Audio Analog Stereo under the output tab instead of Dummy Output.

| improve this answer | |
  • 3
    When I run pacmd list-cards I get "0 card(s) available`. X1C 7th gen, Ubuntu 18.04. Lenovo had to screw up the X1C... 6th gen sound and microphone worked fine in Ubuntu, now they're both f***ed. – Dan Dascalescu Mar 25 at 9:47
2

I faced this as well when I dist-upgraded my custom-built desktop from 16.04.x to 18.04.1 (both LTS). After upgrading, sound didn't work. lspci listed the audio device but -- unlike yours -- the system stubbornly refused to load the relevant module. lshw showed the device as 'unclaimed'.

$ lspci -nnk | grep -A2 Audio
<snip>
00:1f.3 Audio device [0403]: Intel Corporation 200 Series PCH HD Audio [8086:a2f0]
        Subsystem: ASUSTeK Computer Inc. 200 Series PCH HD Audio [1043:8723]
<snip>

$ sudo lshw -c sound
     *-multimedia UNCLAIMED
          description: Audio device
          product: 200 Series PCH HD Audio
          vendor: Intel Corporation

I tried a bunch of Ask Ubuntu and web answers (such as these answers) but they didn't work for me. Eventually I tried the Sound Troubleshooting Procedure on help.ubuntu.com, and Step 3 of the troubleshooting procedures helped me get back sound. Essentially what I did is ran the following commands and rebooted.

sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt-get install linux-image-extra-`uname -r`
sudo apt-get install --reinstall linux-image-extra-`uname -r`  
sudo apt-get install oem-audio-hda-daily-dkms

Now lspci shows (and sound works):

$ lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation 200 Series PCH HD Audio [8086:a2f0]
    Subsystem: ASUSTeK Computer Inc. 200 Series PCH HD Audio [1043:8723]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
| improve this answer | |
  • Thank you for your answer. It did not make any difference. From the list of commands provided only first and last worked (update was automatic). – berduchwal Nov 8 '18 at 8:51
2

I have slight different variation of the problem, the command

lsmod | grep snd_hda_intel

and

lspci -nnk | grep -A2 Audio

both indicated that I have snd_hda_intel on the system, however the audio control have always been Dummy Output.

Following Sound Troubleshooting similar to @sigint, I realized that oem-audio-hda-daily-dkms is the only one needed.

sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get install oem-audio-hda-daily-dkms

Please also refer to the HW I have below

  • MB: ASROCK Z370 Pro4
  • i7 8700k
| improve this answer | |
  • No help. I tried that but it changed nothing for me. – berduchwal Jan 4 '19 at 9:11
  • @berduchwal this sounds silly, but could it be HW problem? e.g. front panel audio wire or connection? I have done this a few times now and it worked on my ASRock and MSI mobo. What kinds of HW you have? – hdev213 Jan 7 '19 at 14:34
  • @berduchwal OK I think I might have found what might be going on. I have faced again this issue today, and I was scratching my head thinking about that is going on... Then I plugged in my headphone and restarted the machine, and all the sudden the headphone option come up. I think this could be due the timing of sound card initialization or it only initialize once at the beginning. I have tested the same theory with the line-in input jack at the back of the machine and same result. I hope this helps. – hdev213 Jan 28 '19 at 21:58
  • Sound initialisation timing sounds a firm possibility. When I reboot sound is Dummy Output but when I unplug and plug back headphones it changes to proper sound card. – berduchwal Jun 8 '19 at 17:35
  • Thanks for this link! help.ubuntu.com/community/SoundTroubleshooting helped me find that linux-image-virtual package does not install sound card drivers, but linux-image-generic does. – Konstantin Pelepelin Mar 5 at 20:31
2

Some other service might be capturing the default audio output before pulseaudio is able to reserve it. Leaving only a "Dummy Output" as (useless) fallback. Check via two commands if there's a discrepancy between what aplay and what pulseaudio sees:

$ aplay -l

$ pacmd list-cards

If the second command does not include your analog output, but aplay lists it, then something is grabbing the analog outputs, preventing pulseaudio from using them. Do you have timidity installed? Try stopping or removing it.

| improve this answer | |
  • 1
    $ pacmd list-cards [0 card(s) available.] $ aplay -l [aplay: device_list:270: no soundcards found...] tried to remove timidity no change. – berduchwal Jan 24 at 10:08
  • Having thought through your answer careful I now come to conclusion that the capturing of sound card idea is probably correct just with a different application. When I use USB sound card it does not work on boot it does not show at all. When I disconnect it and connect it again it starts working. How can I establish which application captures the sound cards? – berduchwal Jan 30 at 12:46
  • Sorry, no idea. For me, it seems there are competing generations of how audio is supposed to work: one, a number of apps that respect pulseaudio as universal audio api, allowing multple to connect; and two: apps that follow a (possibly older scheme) where they capture audio devices on a lower level, and unintendly breaking resource sharing. Your example shows: who comes first, wins. – isync Feb 2 at 0:53
  • I had the situation described in this answer, and was able to track down the program which was getting in the way with sudo fuser -v /dev/snd/* and sudo fuser -v /dev/dsp (as described at wiki.archlinux.org/index.php/PulseAudio/…) @berduchwal – JustATrick Apr 3 at 17:23
0

I tried a bunch of options, including all described here, though the only option that worked for me was appending the line

options snd-hda-intel dmic_detect=0

to the end of the file /etc/modprobe.d/alsa-base.conf

as well as the line blacklist snd_soc_sk

to the end of the file /etc/modprobe.d/blacklist.conf

The lines can be appended to the correspondent files using a text editor (with root privileges) or directly with the commands:

echo "options snd-hda-intel dmic_detect=0" | sudo tee -a

and

echo "blacklist snd_soc_skl" | sudo tee -a /etc/modprobe.d/blacklist.conf

source

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.