0

When I am trying to install Rabbitmq-server I am having this issue for my system.

ERROR I am Facing this.

"the following packages have unmet dependencies: rabbitmq-server : Depends: erlang-nox (>= 1:19.3) but it is not going to be installed or esl-erlang (>= 1:19.3) but it is not installable Unable to correct problems, you have held broken packages. Fatal error: sudo() received nonzero return code 100 while executing! Requested: apt-get install -y rabbitmq-server"

also giving this output.

ubuntu@ubuntu:~$ sudo apt-get update

Hit:2 http://ports.ubuntu.com xenial InRelease

Hit:3 http://ports.ubuntu.com xenial-security InRelease

Ign:1 http://packages.erlang-solutions.com/debian xenial InRelease

Hit:4 http://ports.ubuntu.com xenial-updates InRelease

Hit:6 http://ports.ubuntu.com xenial-backports InRelease
Hit:5 http://packages.erlang-solutions.com/debian xenial Release Reading package lists... Done

N: Skipping acquire of configured file 'contrib/binary-arm64/Packages' as repository 'http://binaries.erlang-solutions.com/debian xenial InRelease' doesn't support architecture 'arm64'

N: Skipping acquire of configured file 'contrib/binary-armhf/Packages' as repository 'http://binaries.erlang-solutions.com/debian xenial InRelease' doesn't support architecture 'armhf'

ubuntu@ubuntu:~$ uname -r

3.14.29

ubuntu@ubuntu:~$ dpkg --print-architecture

arm64

ubuntu@ubuntu:~$ dpkg --print-foreign-architectures

armhf

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.