95

Dual monitor setup on Ubuntu 18.04; when I hit activities only the left monitor switches workspaces while the right monitor just keeps whatever is on its screen. Is there a way to make the workspace span both monitors so that when I switch from one workspace to another both monitors switch?

  • Does this work for both gnome and unity? – Ross Feb 6 '19 at 19:09
  • 6
    Does anyone know how to do the exact opposite of this? How can I have independent workspaces that do not span the monitors? To be clear, I want workspaces to be per-display, as you find with macOS Spaces, for example. – Benjamin R Jun 10 '19 at 13:56
125

Had the same problem. Turned out it was super easy to fix.

Install the GNOME Tweaks app. Go to "Workspaces" and set "Display handling" to "Workspaces span displays". Done!

| improve this answer | |
  • 2
    nice, simple and effective ! – Lefi Tarik Oct 29 '18 at 9:23
  • 4
    see also askubuntu.com/a/1125322/16985 for additional fixes, e.g. Activities still showing windows from all workspaces on secondary display – törzsmókus Mar 13 '19 at 14:04
  • 2
    I had a different problem that this solution fixed. When switching from a single laptop display to a single external display, all the windows were merged into the top workspace, emptying the other workspace. Makes the worksspaces concept useless. Thanks. – AlikElzin-kilaka Jun 26 '19 at 12:22
  • This fixes workspaces but the "window key" dash on additional monitors shows all apps across all workspaces for Ubuntu 18. In Fedora 31, this works. – wilsotc Dec 29 '19 at 15:01
  • worked on ubuntu 19.10 as expected – ErkanA Jan 1 at 16:06
59

You can change this behaviour by executing:

$ gsettings set org.gnome.mutter workspaces-only-on-primary false
| improve this answer | |
  • 8
    This works on Ubuntu 18.04 – elvis.dukaj Nov 20 '18 at 14:13
  • 1
    This worked on my Budgie desktop as well. – Scotty C. Mar 26 '19 at 18:29
  • 1
    This is the only thing that worked for me on 19.10 – ben.bourdin Mar 8 at 11:40
  • 2
    This should be the selected answer, simple and no extra apps required – Steven Apr 29 at 8:45
  • 1
    This work on ubuntu 20.04 – NekoOs May 19 at 22:39
10

You can install gnome-tweak-tool via sudo apt install gnome-tweak-tool.

Then go to Workspaces > Display Handling > And choose Workspaces span displays

| improve this answer | |
  • 3
    I believe this answer is better explained than the most voted. – Dazag Oct 23 '19 at 9:57
  • I don't know where do I find Workspaces :( – webpreneur Jul 16 at 12:13
9

Install dconf-editor

sudo apt install dconf-editor

Disable following settings:

dconf write /org/gnome/mutter/workspaces-only-on-primary false
dconf write /org/gnome/shell/overrides/workspaces-only-on-primary false
| improve this answer | |
  • This is the only solution here that worked for me. – Sean Lynch Oct 11 '18 at 17:48
  • nothing worked for me – leoschet Dec 13 '18 at 15:20
  • @leoschet I suggest you reset dconf settings first. (dconf reset -f /) – Shantanu Saha Dec 18 '18 at 7:43
  • 1
    I don't think you need to install dconf-editor (it's for the GUI application) first in order to run the dconf write ... commands. Also it's preferable to use gsettings instead of the dconf commands (see here). – pomsky Nov 12 '19 at 10:55
7

I recommend to you to use the Multi Monitos Add-on extension, available in GNOME Extensions, it is pretty easy to use, and also it gives you te ability to add a panel in the second monitor.

To get up and running all the gnome extensions config directly in your browser, you only need the following.

  1. Install the gnome-shell-extensions package:

    $ sudo apt install gnome-shell-extensions

  2. Install the host connector:

    $ sudo apt install chrome-gnome-shell

  3. Install the GNOME Shell integration extension (Chrome) or add-on (Firefox)

  4. Find and install the Multi Monitos Add-on extension.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.