I am using an external keyboard on my laptop and the Super key doesn't work. The laptop's keyboard works just fine, every key is regularly detected.

I tried using xinput to debug this issue. Here you can see the output of xinput list, the device I am having issues with is the Cooler Master Technology Inc. MasterKeys Pro L White.

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]
⎜   ↳ Bluetooth  Mouse                          id=16   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Chicony USB 2.0 Camera: Chicony           id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ Cooler Master Technology Inc. MasterKeys Pro L White  id=11   [slave  keyboard (3)]
    ↳ Cooler Master Technology Inc. MasterKeys Pro L White  id=12   [slave  keyboard (3)]

I tried running xinput test-xi2 12 to see if the events from the keyboard where issued. All keys are working except for the super keys. I tested the keyboard with my desktop PC and all keys are working fine.

I am running Ubuntu 16.04.5 with kernel version 4.13.0-45-generic, Unity as Desktop Environment and Compiz as Windows Manager.


Make sure you didn't disable the super key from the keyboard. I have CM Storm Quickfire TK, everything works fine. I can enable gaming mode on the keyboard, and thus disable the super key altogether.

  • Thank you for the answer, I didn't know about this lock key. Now the super key is working fine. – Fabrizio Destro Jul 25 '18 at 20:12
  • same problem here with an Avell notebook. – coderade Feb 7 at 16:02
  • Thank you! My Logitech G710+ keyboard apparently has a key like that as well. :) – L42 May 24 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.