Since the update to 18.04 every YouTube video and also locally played videos hang for a few seconds.

This can be temporarily "solved" by moving the mouse, but then it freezes again as the audio continues unaffected.

How can I fix this problem?

  • 2
    You should post the solution as an answer instead of putting it into question. – SurvivalMachine Jul 25 '18 at 15:41

disabling hardware acceleration in chrome helped me, installing new kernel didn't

  • I must say this solution was definitely unexpected – smac89 Nov 19 '18 at 4:09
  • same for me :-) thankyou!!! now i can boot normally and everything works fine. – Matthias Nov 22 '18 at 11:17

to resolve the issue, simply install kernel 4.3.0 and everything works as expected!

copy/paste the following to terminal:

cd /tmp/
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300_4.3.0-040300.201511020949_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
sudo dpkg -i *.deb

Run these commands and reboot, selecting kernel 4.3 in grub extended settings.

hope this helps, as it did for me.

best regards

  • 1
    Downgrading kernel to fix youtube video issue...nah fam – smac89 Nov 19 '18 at 4:11

I experienced frequent random freezing of a few seconds too and disabling hardware acceleration did nothing for me (also, I don't see how the browser's hardware acceleration can affect the random freezing in other software in OP's case).

The solution in my case was to disable Intel hyperthreading from the BIOS of my machine.


A litte late for the party. I know that the answer above is already accepted, but I want to share my experience which might be helpful for others. The problem was something to do with ACPI. I wrote a script which solves this problem automatically: Fix-video-lag-in-linux.


if grep -q acpi_rev_override "/etc/default/grub"; then
 echo 'Found settings entry, nothing changed';
 sudo sed -i 's/splash/splash acpi_rev_override=1/' /etc/default/grub
 echo "Finished successfully. please reboot to apply the new settings"


if grep -q acpi_rev_override=1 "/etc/default/grub"; then
 sudo sed -i 's/splash acpi_rev_override=1/splash/' /etc/default/grub
 echo "Reset finished successfully"
 echo 'No settings found, exiting.';
  • 2
    Hi Obadah, please do not link to external resources, include your script here. – bummi May 12 '19 at 11:56
  • I included your script here, but this is a really bad idea. You are replacing any instance of the word "splash" without checking if this is the right line for it. This could break your grub installation. And you don't even keep a backup by using sed -i.bak or similar! Your original script was even more dangerous since you were using the g modifier to replace all occurrences of splash. This is either not needed (there should be only one, in fact your script depends on it) or actively dangerous in the unlikely case where there is more than one. – terdon May 13 '19 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.