1

I got a new Dell Laptop and after setting up the pre-installed Win10, i installed Ubuntu 18.04 for dualboot and it worked at first. Even after restarting it, the bootloader appeared. But, after booting windows, the ubuntu bootloader did not appear anymore. The boot entry was still there but instead of booting ubuntu, a Dell hardware check appeared, which didn't find any errors. While checking in the bios i found out, that the ubuntu bootloader in sda1/EFI/ubuntu was already corrupted, as instead of directories and files, it showed parts of error messages.

With the Ubuntu live USB i then ran boot-repair to let it fix any issue. Aftwerwards, ubuntu still couldn't boot, but the filenames in the /EFI/ubuntu directory were changed to names like "FSCK0000.000", "fsck0000.012".

So i tried just reinstalling ubuntu which prompted an error message about a wrong boot partition. The message lead to the conclusion that it tried to install in legacy mode, not efi, which can't really be, as i used the same 18.04 live usb several times before, even on this device. I created then another partition for booting with 200mb and tried to use that. It prompted error messages again which i couldn't fix but since the original boot-directory were already broken i just forced the installation. It finished with the error message, that it couldn't create the boot directory/install grub.

The last idea i had, was to just remove the /EFI/ubuntu directory by myself, as it already is corrupted and i think it is the reason nothing else works. But it turns out, i can't just simply remove the directory because it is corrupted. Linux from the live USB shows an I/O Error when i try to interact with the directory, which is marked as d????????? ? ? ... ? ubuntu. Windows lets me at least view the content of the directory but i can't delete anything because of "PermissionDenied"-IO Exception.

Installing grub manually also doesn't work...

So, right now, after the first reinstallation attempt, the ubuntu setup even freezes at some point. I also don't know how to remove the corrupted boot files/directory and i really don't want to format sda1 (boot partition) as there are the not-courrupted directories Microsoft, Boot and Dell on it.

Does anybody know how i could fix this issue, so i can reinstall Ubuntu Dualboot (I really need both OSes on my machine for my work)? I'm desperate right now

Thank you

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.