2

I purchased a usb wifi adapter that doesn't work or show up in lsusb. Here are the possible reasons I can think of why it wouldn't show up in lsusb:

  1. The usb port is broken
  2. The device is broken
  3. There's something wrong with lsusb

Are there any other possibilities?

I've tested all my USB ports, and they are not at fault. I've also tried it on two computers with the same results. It seems unlikely that lsusb would fail. Unless there is another possible source of error, I must assume that the adapter itself is broken.

edit: the device shows up in Windows device manager, although I'm not able to install the driver. This suggest that the device isn't actually broken, which is even more confusing.

0

The thing is probably dead, lsusb should list devices that are unresponcive but might not. The fact that you can see it in windows just means windows knows somthing's connected to the port, but not that it works.

Pull up the properties on the device in windows and see if you can find the system messages for it; it should, if functional, come up with a device name and the logs should show a device install request which would imply it's working and you should find drivers for it. Windows may also tell you that the device blew an error (giving you evidence it's faulty) should tell you something like "error: 43" if windows thinks it's screwed

GL

  • On Windows, it says it is an "Unknown Device" with Unknown manufacturer. It gives me error code 28 (The drivers for this device are not installed.) I managed to find a driver for it (the rtl8811au driver under network adapters > realtek corp) but it gives me error code 10 (the device failed to start). Guessing that means it's broken, then. – J. Doe Jul 25 '18 at 21:35
  • That's a pretty comfortable way to know it's broken (provided you rebooted drivers don't always work after install) just to be sure you could install the ubuntu drivers manually and see if it comes up but you're gonna have a harder time being certain with that – David N Zilio Jul 26 '18 at 2:17
0

The other possibility is that your operating system (in this case Ubuntu) doesn't have the necessary drivers to get that device to work or even recognize it.

These questions might be helpful to you:

Wifi Dongle not appearing in lsusb
My WiFi adapter is not working at all, how to troubleshoot?

  • Thanks. The first link didn't work for me (nothing shows up in dmesg), but I will check out the other link after work. – J. Doe Jul 25 '18 at 15:48
  • I've tried everything in the second link with no success. It is like, as far as the computer is concerned, the device does not exist. It doesn't show up in any logs. – J. Doe Jul 25 '18 at 22:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.