2

My computer has 1366x768 display. If I use Print Screen, then taken picture will have 1366x768 resolution.
But there is a question: Is it possible to get 1920x1080 picture with my 1366x768 display?

One potential idea I thought is to make 4 virtual desktops like this:

MultiDesktops

But, I do not have an idea how to do this. Any help will be much appreciated.

Edit: Creating Virtual Machine with higher resolution is possible (thanks to @danzel), however I am looking for utilizing more native way using only the Host OS.

Update 1: The output of xrandr --listmonitors:

Monitors: 1
0: +*LVDS-1 1366/344x768/194+0+0  LVDS-1

$ sudo xrandr --addmode LVDS-1 1920x1080
xrandr: cannot find mode "1920x1080"

Update 2: Thanks to comment of user @Eate the question was solved by adding the custom resolution:

$ cvt 1920 1080
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
$ sudo xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
$ sudo xrandr --addmode LVDS-1 1920x1080_60.00

Then go to Display Settings and select 1920x1080.

  • Do you want an image on one window (larger than your real screen)? Do you have a setup with multiple desktops where a window can be larger than a screen? – Volker Siegel Jul 24 '18 at 16:39
  • @Volker Siegel, yes. Actually, I want to take the screenshot of Firefox's window. But, I did not have a setup with multiple desktops... – Olimjon Jul 24 '18 at 16:41
  • @Olimjon the question is a bit unclear. Do you want to make a screenshot of a window that has 1920x1080 pixels, or do you want to make a screenshot of a 1366x768 pixel window and resize it to 1920x1080 pixels? BTW it is perfectly possible to run a virtual machine in a higher resolution than the screens attached to the host. – danzel Jul 24 '18 at 17:21
  • @danzel, Well, imagine that there is a display with 1920x1080. In this display I press the button <kbd>Print Screen</kbd> and a 1920x1080 picture appears in the clipboard. So, I want to achieve this result with the lower resolution without any resizing. And in my desktop any window cannot have the pixels beyond 1366x768, so I should find a way out. – Olimjon Jul 24 '18 at 17:33
  • @danzel, Regarding to your BTW section. Yeah, I was wrong. I will edit the question... – Olimjon Jul 24 '18 at 17:37
1

Step 1

Try changing the resolution in Settings first. Go into Settings, and, depending on what version you're on, work your way into Displays. For 18.04, this is under Devices/Displays. Change screen resolution to the resolution you want, for example 1920×1080. Take a screenshot with that new resolution, and then change it back when you're done.

Step 2

If the resolution you need is not available, use this command to calculate the CVT mode lines for the resolution you want:

cvt 1920 1080

This example is for 1920×1080. It should output something like this:

1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Copy all of the text after Modeline (here, it is "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync) and remember to include the quotation marks in the beginning. To add the new mode so you can use it, run this command:

sudo xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Use your modeline output in place of mine. Then, to add that new mode to your display so you can use it, you will need to know what the name of your monitor. To do that, run this:

xrandr

This will output a few lines. On the second line, you should see something like this:

(monitor_name) connected primary ...

That monitor name is your monitor's device name. To add the new resolution you added to your monitor, run this command:

sudo xrandr --addmode (monitor_name) "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Again, substitute in the monitor name you get from the previous step and the stuff after that from the cvt command. You have added the new resolution. Now, go back and try step 1.

  • OK, my display does not support 1920x1080. For me, the highest display resolution is 1366x768. – Olimjon Jul 24 '18 at 17:58
  • Try sudo xrandr --addmode default 1920x1080 – Eate Jul 24 '18 at 18:01
  • The output: xrandr: cannot find output "default" – Olimjon Jul 24 '18 at 18:02
  • I will edit the question to include more details... – Olimjon Jul 24 '18 at 18:04
  • Try xrandr --fb 1920x1080 – Eate Jul 24 '18 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.