0

This question already has an answer here:

I just started with Ubuntu 18.04. Everything else seems to be fine, but it does not recognize my WiFi card. I also tried getting a USB WiFi and it does not recognize that either.

What I have:

chris@chris-HP-Laptop-15-bs0xx:~$  lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5904] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 620 [8086:5916] (rev 02)
00:04.0 Signal processing controller [1180]: Intel Corporation Skylake Processor Thermal Subsystem [8086:1903] (rev 02)
00:08.0 System peripheral [0880]: Intel Corporation Skylake Gaussian Mixture Model [8086:1911]
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21)
00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] [8086:9d03] (rev 21)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 [8086:9d14] (rev f1)
00:1c.5 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 [8086:9d15] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:9d4e] (rev 21)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21)
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:d723]


chris@chris-HP-Laptop-15-bs0xx:~$  lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0408:5220 Quanta Computer, Inc. 
Bus 001 Device 003: ID 0bda:b009 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 0846:9052 NetGear, Inc. A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I tried this: https://askubuntu.com/a/996618 and it did not work.

marked as duplicate by Pilot6, pomsky, karel, Kevin Bowen, Thomas Jul 25 '18 at 9:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • "It didn't work" doesn't give any information. Probably you didn't disable Secure Boot in BIOS. – Pilot6 Jul 24 '18 at 14:03
  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Jul 24 '18 at 14:04
  • 1
    @Pilot6 I think OP has RTL8723DE, but OP tried the answer with older module which is incompatible with newer kernels (OP has 18.04). – pomsky Jul 24 '18 at 14:08
  • OK, but we don't know of that was the problem. – Pilot6 Jul 24 '18 at 14:10
  • Thanks both. Pilot6, you were right, it was the Secure Boot. Took me a while to figure out how to turn that off. Once I did the Wifi worked. – Chris Jul 25 '18 at 19:12
0

See this answer

For kernel 4.15 you need this:

sudo dkms remove rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414 --all
sudo apt update
sudo apt install git dkms
git clone https://github.com/smlinux/rtl8723de.git -b 4.15-up
cd rtl8723de
sudo dkms add .
source dkms.conf
sudo dkms install $PACKAGE_NAME/$PACKAGE_VERSION   

Not the answer you're looking for? Browse other questions tagged or ask your own question.