3

I've been trying to get Ubuntu 18.04 LTS running on my new MSI GE63 Raider. I can get into the live USB by passing acpi=off and then running the installer. After that, I install the proprietary nvidia driver (nvidia-driver-390). Also I have tried installing nvidia-prime and bumblebee. I've also blacklisted nouveau.

The issue is that I cannot for the life of me get it to boot without passing acpi=off, because otherwise it hangs at a purple screen. When trying in recovery mode with any of the included kernels (4.15.0-20 and 4.15.0-29) I can see it hangs at

Loading initial ramdisk.

In addition to the above I tried passing following parameters in GRUB:

  • acpi=ht
  • acpi_osi=
  • acpi_osi=! acpi_osi="Windows 2009"
  • acpi_osi=! acpi_osi="Linux"
  • nomodeset
  • nogpumanager

... and a couple more (I forget after trying so many)

The specs of this laptop are:

  • intel i7 8750h (6 core)
  • nvidia gtx1060m
  • 16gb of RAM
  • 256gb ssd (which holds the windows 10 partition and the "/"
  • 1000gb hdd (which holds the data for windows and "/home"

The BIOS settings are set to UEFI. Fast boot and secure boot are both disabled. I've also tried switching off Intel speedstep and c-states, both to no avail.

Also, I have tried to install Debian 9, Lubuntu 17.04, Ubuntu 16.04 LTS, Deepin 15.5 and Mint 18, all of which need the added acpi=off flag.

Does anyone have any advice for this?

Thanks in advance!

2

I ended up doing a bios update. I had to disable fastboot and secureboot again after that, and now it works like a charm!

  • Hello, I have the same laptop and the same problem. So I wanted to follow you, but I have problem updating the bios. I downloaded the latest BIOS version from MSI's website, copied the files to a USB, and followed the steps. But when it says system will power off and then power on automatically, it does not do anything. Bios menu stalls. Do you have an idea what would be the reason? – Amadeus Bachmann Jul 27 '18 at 18:09
  • 1
    Make sure to re-enable secure boot and fast boot before doing firmware update or it will not work. – AlexIIP Oct 20 '18 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.