I have a Huawei K3765 (USB ID 12D1:1520) and I'm trying to use it with Ubuntu 10.04 Lucid.

I have usb-modeswitch installed, so when I plug the device I can see that it gets switched from storage-mode to modem-mode. My problem is that when I try to create a broadband mobile connection for it, NetworkManager doesn't detect the modem... I tried this on two different laptops. /var/log/daemon.log doesn't show anything of interest, AFAIKT... What could I try?


I had the same problem on 12.04 and the solution was to boot the machine with the dongle already inserted.
Ensure that the modemmanager package is installed.

  • But this 'solution' is for 12.04 LTS, not 10.04 LTS. – david6 Mar 10 '13 at 9:12
  • Yes, but I'm not using 10.04 anymore – Joril Mar 10 '13 at 9:55
  • So problem does not exist for 12.04, or this solved issue for 10.04? – david6 Mar 10 '13 at 10:50
  • The problem does exist for 12.04, but I cannot test this on 10.04 anymore – Joril Mar 10 '13 at 14:37

open Synaptic Package Manager Type "Smartlink" into the search field in the Synaptic Package Manager and install all of smarlink package. http://www.ehow.com/how_5435902_install-modem-drivers-ubuntu.html#ixzz2BcaT8Ean it works with me very well


Try this my brother: http://kaamka.blogspot.com/2011/05/tata-photon-on-ubuntu-1004-lucid-lynx.html

Solution :

STEP 1: In order to work it perfectly following packages are required : 1.usb-modeswitch-data 2.usb-modeswitch

These packages can be downloded from debian site.Links are : http://packages.debian.org/squeeze/usb-modeswitch-data http://packages.debian.org/squeeze/usb-modeswitch

Download the latest version available. For me following versions worked : usb-modeswitch-data(20100826-1) usb-modeswitch(1.1.4-1)

These packages can be installed by selecting and right click , install with debi installer it will ask you password and done. Advance users can install from command line.Goto the packages folder and run following commands : Suppose you have saved on Desktop :

cd /home/user/Desktop sudo dpkg -i usb-modeswitch-data_20100826-1_all.deb sudo dpkg -i usb-modeswitch_1.1.4-1_i386.deb

STEP 2: Now we are going to add our modem to List of Huawei, newer modems in a file. The file name is 12d1:1446 and it is located at /etc/usb_modeswitch.d

Open this file from command line by using following command. sudo gedit /etc/usb_modeswitch.d/12d1:1446

A text editor will pop-up, where you only need to add 140b in the TargetProductList= line and save your file. For your reference, the line should be edited as given below. TargetProductList="1001,1406,140c,141b,14ac,140b"

STEP 3 : Detach your USB Tata Photon+ EC1261 and insert it again. Most probably your modem should be automatically detected. Right click on Network Manager from the top menu bar, select edit connections, select Mobile Broadband and click on Add. You shall be able to find your modem.

STEP 4: For the people with extreme bad luck : If still your device is not detected run following command:

sudo usb_modeswitch -c /etc/usb_modeswitch.d/12d1:1446

In my case i have to run this every time i logon to system.


Sorry.Above solution is not for Huawei K3765.My fault.

I think here the answer. But you just have to make some adjustment at point no.2 and no.3. See the additional tip below. http://ubuntuforums.org/showthread.php?s=ce0f5525713ec13179197c7604ec206e&t=1472896&page=2

DETAILED SOLUTION (as example, with my huawei 1750):

1) Code: sudo apt-get install usb_modeswitch 2) then make its conf file (/etc/usb_modeswitch.conf) look like:

Code: DefaultVendor= 0x12d1 DefaultProduct= 0x1446

TargetVendor = 0x12d1 TargetProduct= 0x1001 MessageContent="55534243000000000000000000000011060000000000000000000000000000" MessageEndpoint=0x01 CheckSuccess=5 3) Then make the Udev rule, to launch usb_modeswitch, when the stick is found (/etc/udev/rules.d/15-huawei-e1750.rules):

Code: SUBSYSTEM=="usb", SYSFS{idProduct}=="1446", SYSFS{idVendor}=="12d1", RUN+="/usr/sbin/usb_modeswitch"

Some additional tips: Above method is only for huawei 1750. If you have different model, change idProduct in point 3 and DefaultProduct in point 2. It's to be easily found by simple lsusb command. Don't change "Target" params.

If you wanna use some else manufacturer's modem, try changing also Vendor Id, but i don't know what should be as Target Product Id. Maybe some generic modem (some even, low, nice number )

!!!IMPORTANT!!! But, there are always some sour buts. The problem lies in the "MessageContent" and the "Message Endpoint". They are different for every model of modem and can be found by using some USB sniffer program, similiar to Ethernet or wifi sniffers. They say it's easy with Windows programs. But i didn't manage to get info using Linux programs and using Wine showed no messages either.

Much of Luck

  • Thanks, but I don't think it's a problem with modeswitch, as I said the device gets switched from storage-mode to modem-mode – Joril Mar 4 '12 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.