0

Recently the touchpad right-button stopped working as such and instead started behaving a left-button. For example, when I select text and right-click, instead of the expected context menu, the text gets deselected.

My mouse's right-button does work as expected.

It's a Dell Inspiron 7577 with Ubuntu 18.04 LTS.

How can I resolve this?

1

You can set it without installing gnome tweaks using

gsettings set org.gnome.desktop.peripherals.touchpad clickmethod "areas"

To set it back use

gsettings set org.gnome.desktop.peripherals.touchpad click-method "fingers"
|improve this answer|||||
3

Here is the answer.

Summary:

  1. Ubuntu 18.04 changed touchpad behavior: By default, you "right-click" by tapping with two fingers.
  2. You can get back the right-button by installing gnome-tweaks, then Keyboard and Mouse -> Area.
|improve this answer|||||
  • sorry, showed you 1st the wrong way; i've myself disabled the finger function but didn't recognized it. Deleted the wrong answer. – abu_bua Jul 26 '18 at 8:57
  • +1 for info about two finger tap for right click. – Abdullah Leghari Feb 7 '19 at 14:55
0

Apparently you reversed them. Go into Settings, then Keyboard & Mouse. At the top you'll see where you can select which is your 'main mouse button'. Click left and then you're all set!

|improve this answer|||||
  • There was no reversal. I had no rightclick functionality at all, just leftclick from both sides of the touchpad – Joshua Fox Jul 29 '18 at 4:23
  • That's odd. I don't know then, sorry. – AlphaWolf Jul 29 '18 at 18:53
  • @alphaWold No problem, the issue was solved; see above – Joshua Fox Aug 1 '18 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.