1

I have tried the usual things of disabling my ipv6 and have changed the conf files too but my wifi is very slow. Here is the content of the file

cat /etc/modprobe.d/iwlwifi.conf 
# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211
options iwlwifi 11n_disable=1

Ubuntu version

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04 LTS
Release:    18.04
Codename:   bionic

The power management is also off

wlp4s0    IEEE 802.11  ESSID:"CLUMIO-SECURE"  
          Mode:Managed  Frequency:5.745 GHz  Access Point: 20:A6:CD:A9:38:71   
          Bit Rate=48 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=61/70  Signal level=-49 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:85   Missed beacon:0

Network controller info from lcpci

04:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

Anything else I can try? This is so slow, I get like 18Mbps, while the person next to me gets like 50Mbps

2
  • Any big improvement if you change iwlwifi.conf to have 11n_disable=8 – Jeremy31 Jul 24 '18 at 11:35
  • @Jeremy31, I have done that too in the past and nothing changes – curiousengineer Jul 24 '18 at 15:44
0

I'ts a shot in the dark, but could you try setting up a static ip for your specific laptop? I know it does not solve the issue with your laptop and card, but it would at least allow you to game, or surf the web while you figure out another option. I'm not a networking person by any metric, just thought it might be a look from outside the box. Also, its probably sounds dumb to ask this, but have you looked for an update for the card in Intel's database of drivers? something like this https://www.intel.com/content/www/us/en/support/articles/000005480/network-and-i-o/ethernet-products.html It's just a random page I found for Intel NIC drivers, but it's a starting point.

0

Check your kernel version with uname -a. If the version is 5.1 or greater, it should support your hardware without needing the iwlwifi driver.

Remove the iwlwifi driver (cautiously if you don't have an ethernet backup):

  1. apt search ilwwifi. You should see something like:
Sorting... Done
Full Text Search... Done
backport-iwlwifi-dkms/focal,focal 8324-0ubuntu1 all iwlwifi driver backport in DKMS format

oem-wifi-iwlwifi-mainline-5.1rc1-dkms/now 6 amd64 [residual-config] (none)
  1. Remove each that is installed on your machine. For example apt remove backport-iwlwifi-dkms oem-wifi-iwlwifi-mainline-5.1rc1-dkms
  2. Reboot if needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.