2

I just got a new computer, and I'm wanting to install Ubuntu. Right now I'm just running the live image from USB, and everything seems to work great...except the touchscreen.

The touchscreen works in both BIOS and Win10, so I know the hardware is good. Win10 recognizes it as:

HID\ELAN2097&Col01\5&335340af&0&0000

However when I boot my 18.04 Ubuntu live usb (4.15.0-20 kernel), the touchscreen doesn't even show up at all under xinput or lsusb. Completely missing. This is all I get under the pointers:

Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]

I've checked the syslog, and haven't found anything mentioning Elan, but I'm not really sure exactly what I'm looking for. I've tried two different ISO images (Ubuntu and Xubuntu, both 18.04).

My other computer is a 2 year old XPS 13, also with an Elan touchscreen. This is what i get from xinput on it (same as above, except also this line just above the Synaptics):

⎜   ↳ ELAN Touchscreen                          id=10   [slave  pointer  

Likewise on the XPS I get this in lsusb:

Bus 001 Device 003: ID 04f3:20d0 Elan Microelectronics Corp. 

That's my only reference point, I've been searching here and elsewhere and haven't found anything about this. Any help would be greatly appreciated!

2

Solved: I was using a grub2 usb drive to load an ISO. I tried making a new disk (from same ISO) using Startup Disk Creator. Worked perfectly. This is what I get from xinput now.

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ DELL07EB:00 06CB:7E7E Touchpad            id=12   [slave  pointer  (2)]
⎜   ↳ ELAN2097:00 04F3:2364                     id=13   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=19   [slave  pointer  (2)]

Got me to thinking, so I compared the grub.cfg. The most obvious thing was the boot=... acpi_osi= ... in my other cd. So I removed the acpi_osi= and booted again, and again it worked fine.

(I had the acpi_osi= in there because of hardware issues on my XPS13...backlight keys, I think)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.