0
  1. I created 2 machines: Windows 10, Ubuntu 18.04.
  2. I installed Webmin 1.881 then, installed Samba Windows File Sharing (by Webmin) in Ubuntu
  3. I created a folder to be shared in Ubuntu.
  4. I went to WEBMIN > System > Users & Groups and created a user with password and include it in the Sambashare group.
  5. I converted the user to a Samba user by WEBMIN
  6. I went to WEBMIN > Servers > SAMBA Windows File Sharing and created a new file share of the folder I had created (I set create with group = Sambashare).
  7. I ran the command: sudo pdbedit -L, and the user was listed
  8. I ran the command: testparm -s. The output was:

    Load smb config files from /etc/samba/smb.conf
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    WARNING: The "syslog" option is deprecated
    Processing section "[printers]"
    Processing section "[print$]"
    Processing section "[test222]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    
    # Global parameters
    [global]
            dns proxy = No
            log file = /var/log/samba/log.%m
            map to guest = Bad User
            max log size = 1000
            obey pam restrictions = Yes
            pam password change = Yes
            panic action = /usr/share/samba/panic-action %d
            passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
            passwd program = /usr/bin/passwd %u
            server role = standalone server
            server string = %h server (Samba, Ubuntu)
            syslog = 0
            unix password sync = Yes
            usershare allow guests = Yes
            idmap config * : backend = tdb
    
    
    [printers]
            browseable = No
            comment = All Printers
            create mask = 0700
            path = /var/spool/samba
            printable = Yes
    
    
    [print$]
            comment = Printer Drivers
            path = /var/lib/samba/printers
    
    
    [test222]
            path = home/hiddai/linshare
    
  9. I restarted the SAMBA service.

  10. I went to WIN 10 > run and typed: \\UBUNTU_IP\{ShareFolderName}
  11. I typed in username:

    '{username}' , password: ******
    'UBUNTU1804\\{username}' , password: ******
    

    As a result I got a message 'Access is denied' and I ask WHY?

  • Add to your original question the output of the following command - without quotes: "testparm -s" – Morbius1 Jul 24 '18 at 11:33
0
[test222]
        path = home/hiddai/linshare'
  • That is a read only share so if you try to add something to it Win10 will issue a Destination Folder Access Denied error.

  • Although it is not a problem for samba and it will work just fine as it is from a Linux perspective your path is missing a leading / as in /home/hiddai/linshare

  • I don't know if that apostrophe at the end of linshare' is a typo or if that is the real name of the folder. If it's a typo Win10 will issue a Windows cannot access \\server\test222 error.

  • And one other complication may be if hiddai's home directory is encrypted. If it is then only one user will be able to access that share and that is hiddai.

If your intent was to create a writeable share that requires authentication to access on a folder in an encrypted home folder you might want to see if something like this works better:

[test222]
        path = /home/hiddai/linshare
        read only = No
        force user = hiddai 
| improve this answer | |
0

The credentials weren't including the password.

I found that when I checked the converted user in WEBMIN > SAMBA Windows File sharing > Samba users. The user's password wasn't set.

Logging in with username only solved the problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.