0

Running apt-get update today refuses to update repositories as it doesn't think they are signed. At first it just gave the At least one invalid signature was encountered error for all repositories, but after trying to run apt-get clean, cleaning trusted.gpg.d, etc. it now says the repositories themselves are not signed.

I have tried several mirrors, and this same error comes from PPAs too. (I have removed them from the log)

How I can fix this?

$ sudo apt update
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Get:2 http://fi.archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Err:1 http://security.ubuntu.com/ubuntu xenial-security InRelease   
  At least one invalid signature was encountered.
Get:3 http://fi.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Err:2 http://fi.archive.ubuntu.com/ubuntu xenial InRelease   
  At least one invalid signature was encountered.
Get:4 http://fi.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Err:3 http://fi.archive.ubuntu.com/ubuntu xenial-updates InRelease
  At least one invalid signature was encountered.
Err:4 http://fi.archive.ubuntu.com/ubuntu xenial-backports InRelease
  At least one invalid signature was encountered.
Reading package lists... Done
W: GPG error: http://security.ubuntu.com/ubuntu xenial-security InRelease: At least one invalid signature was encountered.
E: The repository 'http://security.ubuntu.com/ubuntu xenial-security InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://fi.archive.ubuntu.com/ubuntu xenial InRelease: At least one invalid signature was encountered.
E: The repository 'http://fi.archive.ubuntu.com/ubuntu xenial InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://fi.archive.ubuntu.com/ubuntu xenial-updates InRelease: At least one invalid signature was encountered.
E: The repository 'http://fi.archive.ubuntu.com/ubuntu xenial-updates InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://fi.archive.ubuntu.com/ubuntu xenial-backports InRelease: At least one invalid signature was encountered.
E: The repository 'http://fi.archive.ubuntu.com/ubuntu xenial-backports InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
  • 1
    That's what I thought too, but the accepted answer (or the clean && /apt/lists removal) didn't help in this case. – hotmultimedia Jul 23 '18 at 17:02
  • (my comment was an answer for now deleted comment suggesting that this is duplicate of askubuntu.com/questions/849822/…) – hotmultimedia Jul 23 '18 at 18:40
0

I had accidentally littered busybox symlinks around my own filesystem. This caused apt-key's gpgv-method to fail and that caused the key errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.