I am trying to install Ubuntu 18.04 from a USB stick.

My computer setup is as follows:

  • MB: Asus X99-A USB3.1
  • CPU: Intel 5960X
  • GPU: Nvidia GTX 970
  • Screen (it might be relevant): Asus ROG Swift PG278Q (only possible to run with DP)

I have done some troubleshooting:

  1. Update to latest BIOS and restore to optimized defaults
  2. Disabled Fast Boot
  3. Disabled Secure Boot

These changes have not had any effect on the current problem.

This system should run as a dual boot with Windows 10 which is installed in UEFI mode. I have also tried to install in legacy mode. I see the purple screen, then after several seconds there is a crash with other graphic errors. The graphical error in the picture below is when trying to install in UEFI mode.

Picture of screen as it freezes on install
picture of screen as it freezes on install

I know that this is probably not enough information to solve the issue, so please ask for the information you would think is relevant.

I can add that I have had similar errors when installing Ubuntu 16.04 and Linux Mint 19. I did somehow manage to install Linux Mint 18.1 a couple of years ago.

  • Secure boot and UEFI are okay if you want to install with them enabled, I did find with them enabled. Preinstall check, drive is in AHCI mode, and if graphics is causing problem, enable only intel or discrete graphics, avoid auto or hybrid, disable any overclocking or tweaking, and probably also disable virtualization. Try the UEFI install again to see if it makes any difference. Jul 23, 2018 at 22:08

1 Answer 1


This problem was solved by running the start-up parameter nomodeset

Reference to these answers:



Not the answer you're looking for? Browse other questions tagged or ask your own question.