5

I'm trying to change the behavior of the right click menu in ubuntu 10.10 because I use Windows 7 and Ubuntu.

When you right click you need to hold the right click and select something.

In Windows the is different right click (release) select something with left click

Is there a way to change this in ubuntu?

I'm running the ubuntu in vmware 7

Is that behavior normal?

  • This is so annoying ... – Raffael May 7 '14 at 19:04
1

This is not the normal behaviour in Ubuntu. The normal behaviour is the same as you described for Windows.

As far as I know, there is no way to change this right click behaviour.

It might be a problem with running Ubuntu in vmware, although I can't think how this would make a difference. You could try dual booting or using a different virtualisation solution such as virtualbox.

Was it like this when you first installed Ubuntu? Also, are you running Ubuntu or Kubuntu? (You tagged your question with KDE, which is only installed by default in Kubuntu).

  • thx for your answer, i'll try the dual boot. the tag was a mistake. thx for your help :) – Berty Nov 2 '10 at 8:09
3

At least in newer Ubuntu versions, this is a design decision. There seems to be no way to change the default behaviour.

Behavior: click and hold the right button and then release on the chosen menu option.

Sources:

  • This should be the accepted answer! – vanadium Jan 25 at 13:24
3

It's really annoying behaviour for mouse when it opens context menu on right-click-down event, I tried to fix it in driver level but I couldn't. But I found very reliable workaround to fix it.

1) Install Easystroke Gesture Recognition from repository

sudo apt-get install easystroke

2) Open Easystroke then go to preferences tab, in Behavior section click Gesture Button

and right click on the rectangular area in Select a Mouse or Pen Button window.

3) In Timeout Profile dropdown list pick up Timeout Off

That's all! You don't need to add an action

  • Thanks a lot, I poured some water into my external Thinkpad USB keyboard and now the right and middle click trigger at the same time so I couldn't scroll any more with the middle click. With this solution, it is bearable again (still some issues but this will do until I get replacement parts). – nh2 Jul 18 '18 at 15:11
  • This does work, but damn you can now draw on screen with right click... overkill. But right click works as in windows. – Cipi Mar 19 at 17:14
  • @Cipi you can disable drawing on screen. easystroke show >preferences>Method to show gestures>None – kenn Mar 19 at 17:45
  • @kenn yes, but they're still being handled. You get the annoying PING when you rightclick-drag, but.. who cares... it works. :D – Cipi Mar 20 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.