4

I have problem with DaVinci Resolve 15. After installation app doesn't start. I use makeresolvedeb_15.0b6 to make .deb package. Logs:

#TIME Sat Jul 21 12:15:20 2018 - Uptime 00:00:01 (hh:mm:ss)
#PROGRAM_NAME DaVinci Resolve v15.0.0b.065 (Linux/Clang) 
/opt/resolve/bin/resolve() [0x3ef09e9]
/opt/resolve/bin/resolve(_ZN7BtDebug14ReportSegfaultEiP7siginfoPv+0x6c) [0x3eeffec]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x12890) [0x7f7f335a3890]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xc7) [0x7f7f315c4e97]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x141) [0x7f7f315c6801]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x939c) [0x7f7f4b25639c]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x94c6) [0x7f7f4b2564c6]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x22036) [0x7f7f4b26f036]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x223a1) [0x7f7f4b26f3a1]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x228f7) [0x7f7f4b26f8f7]
/opt/resolve/bin/../libs/libc++abi.so.1(__gxx_personality_v0+0x6c) [0x7f7f4b26fddc]
/lib/x86_64-linux-gnu/libgcc_s.so.1(_Unwind_RaiseException+0x14b) [0x7f7f31987b6b]
/opt/resolve/bin/../libs/libc++abi.so.1(__cxa_throw+0x66) [0x7f7f4b26e9c6]
/opt/resolve/bin/resolve() [0x92f034]
/opt/resolve/bin/resolve() [0x92e829]
/opt/resolve/bin/resolve() [0x9268fa]
/opt/resolve/bin/resolve() [0x8f053c]
/opt/resolve/bin/resolve() [0x8edd7e]
/opt/resolve/bin/resolve() [0x8ec935]
/opt/resolve/bin/resolve() [0x8ec218]
/opt/resolve/bin/resolve() [0x928343]
/opt/resolve/bin/resolve(_ZN7BtDebug14ReportSegfaultEiP7siginfoPv+0x4d7) [0x3ef0457]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x12890) [0x7f7f335a3890]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xc7) [0x7f7f315c4e97]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x141) [0x7f7f315c6801]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x939c) [0x7f7f4b25639c]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x94c6) [0x7f7f4b2564c6]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x22036) [0x7f7f4b26f036]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x223a1) [0x7f7f4b26f3a1]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x228f7) [0x7f7f4b26f8f7]
/opt/resolve/bin/../libs/libc++abi.so.1(__gxx_personality_v0+0x6c) [0x7f7f4b26fddc]
/lib/x86_64-linux-gnu/libgcc_s.so.1(_Unwind_RaiseException+0x14b) [0x7f7f31987b6b]
/opt/resolve/bin/../libs/libc++abi.so.1(__cxa_throw+0x66) [0x7f7f4b26e9c6]
/opt/resolve/bin/resolve() [0x92f034]
/opt/resolve/bin/resolve() [0x92e829]
/opt/resolve/bin/resolve() [0x9268fa]
/opt/resolve/bin/resolve() [0x8f053c]
/opt/resolve/bin/resolve() [0x8edd7e]
/opt/resolve/bin/resolve() [0x8ec935]
/opt/resolve/bin/resolve() [0x8ec218]
/opt/resolve/bin/resolve() [0x928343]
/opt/resolve/bin/resolve(_ZN7BtDebug14ReportSegfaultEiP7siginfoPv+0x4d7) [0x3ef0457]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x12890) [0x7f7f335a3890]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0xc7) [0x7f7f315c4e97]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x141) [0x7f7f315c6801]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x939c) [0x7f7f4b25639c]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x94c6) [0x7f7f4b2564c6]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x22036) [0x7f7f4b26f036]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x223a1) [0x7f7f4b26f3a1]
/opt/resolve/bin/../libs/libc++abi.so.1(+0x228f7) [0x7f7f4b26f8f7]
Signal Number = 6

================================
[0x7f7f29bd8480] | Main                 | INFO  | 2018-07-21 12:15:20,369 | Updating display GPU information...
OpenCL error -1001, GPUPropertiesUtilUnix.cpp:338.
terminating


My soft: Ubuntu 18.04
My device: Dell XPS 13
Intel® UHD Graphics 620 (Kabylake GT2) 
Intel® Core™ i7-8550U CPU @ 1.80GHz × 8
16 GB RAM
9

Unfortunately I am not able to provide a solution. But maybe I can share some insight. I also tried to install DaVinci Resolve (DaVinci_Resolve_15.0b7_Linux) today on an almost identical system (Lubuntu 18.04, same CPU, same Graphics, same Memory, but an HP) and had the same error. I believe that our Graphics is just not good enough for Resolve. If you check their forum you will find them saying again and again that Resolve requires a good GPU.

I got a step further by installing OpenCL with the following command:

apt-get install beignet clinfo

and then checking with:

clinfo

(see also: Install OpenCL on Ubuntu 17.04, intel)

This solved the above error and the welcome screen of DaVinci Resolve was showing. But then I still got the error message, that no OpenCL capable GPU was found. screenshot of error message

Some comments on the DaVinci forum also mention, that even if you get Resolve starting up with this kind of low-end GPU, you will not be able to work properly with it...

  • 1
    Thank you. Now I have the same error like you. Any ideas? – MaksPL Jul 28 '18 at 6:58
  • I believe it would require a better GPU to work. Which is a bit problematic with a notebook. There are external GPUs (eGPU) available, but I have no experience if they would connect to the Dell XPS 13 and if they work under Ubuntu. I went back to my previous editor (Shotcut), which does most of what I need. – stefitz Aug 2 '18 at 10:24
  • 1
    I use OpenShot now and Lightworks. This is amazingly that DaVinci Resolve works on any device but... with Windows. Maybe you're right. I give up with Resolve. – MaksPL Aug 6 '18 at 6:15
  • 1
    This fixed it for me. I'm getting to the splash screen now. Before I was getting nothing. – WhiteHotLoveTiger Aug 18 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.