1

I am trying install cuda on ubuntu 16.04. Have followed the below steps to do so.

sudo dpkg -i cuda-repo-ubuntu1604-9-2-local_9.2.148-1_amd64.deb
sudo apt-key add /var/cuda-repo-<version>/7fa2af80.pub
sudo apt-get update
sudo apt-get install cuda

However, I am getting the below error when executing the last line.

"""Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: cuda : Depends: cuda-9-2 (>= 9.2.148) but it is not going to be installed E: Unable to correct problems, you have held broken packages.""""

Not exactly sure where the issue is. I also tried uninstalling and deleting older version but still no success.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.