1

I have just installed kubuntu 18.04 and I have no man pages. I have tried all the different permutations of mandb to update the database, but I am always presented with a blank page. Any help appreciated.

Many thanks

2
  • 3
    No manpages != man showing blank page. For some particular manpage, say less, what does man -w less output? If it shows a file path, is that file non-empty? Does env -i TERM=$TERM /usr/bin/man less show the manpage? – muru Jul 22 '18 at 7:16
  • Did you solve your problem? If you did, please post the solution as an answer. It may help others with the same issue. – DK Bose Jul 25 '18 at 4:23
1

For anyone else interested, I was having this same issue on Ubuntu 18.04 on two separate devices. I tried reinstalling mandb, groff, and manpages, but none of these worked. However, when I tried env -i TERM=$TERM /usr/bin/man <command> (like @muru suggested) the manual pages appeared. I then modified my /.bashrc with an alias to this command. While it's not a cure to the problem, it is an acceptable workaround for me.

0

Not an answer, but a clarification and expansion:

No man pages in Kubuntu-18.04 != no man pages in the system. I too rely on Konqueror to read man (and info) pages. I especially appreciate the ability to go into finer detail on ancillary pages by right-clicking to open in a new tab or window. e.g. from the lvm manpage open new elements for pvcreate, vgcreate and lvcreate, and be able to quickly switch back and forth. I find reading man (and info) pages in Konqueror to be much more flexible and useful than on a terminal window (konsole) or the K Help Center.

At least on my system, I have no trouble issuing a "man whatever" command from the command line and opening up a man page, I just can't do it from within Konqueror.

Curiously, the Konqueror kio-slave for the man pages starts to work. If I enter "man:" into the URL field, it show all of the sections where the pages may be loaded; from man:/(0)/ to man:/(l)/ [that's a lower case L, not a one]. But that's as far as it will go. In the past, I could enter "man:ls" and the ls manpage would pop up. Now there's just a blank page.

Searching through the system, I find the kio-slaves for the man and info pages, but I can't find any of the kio-slaves for compression. According to https://docs.kde.org, there are kio-slaves for xz/lzma, bzip/bzip2 and gzip, but I can't find any of them on my system, nor can I figure out which packages is supposed to have them.

My guess is that since all of the manpages are gzipped, Konqueror can't display them since the gzip kio-slave isn't present on the system.

I have a backup of Kubuntu 16.04 which I made just before upgrading to 18.04. If I can't find the compression kio-slaves for Kubuntu 18.04, I may revert back to 16.04 and do some experimentation there to see if my suspicion is correct.

If someone knows which package contains the compression kio-slaves, please let me know.

Thanks, ron

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.