I am trying to speed up my boot time because currently windows boots up faster from my secondary disk drive opposed to Ubuntu 18 on my SSD.

After looking at other post I use the command systemd-analyze blame and it returned the following:

     `21.037s plymouth-quit-wait.service
      20.748s fwupd.service
      8.014s tlp.service
      6.103s NetworkManager-wait-online.service
      2.281s snap-gnome\x2dcharacters-103.mount
      2.241s snap-gnome\x2dcharacters-101.mount
      2.239s snap-htop-381.mount
      2.231s snap-gnome\x2d3\x2d26\x2d1604-70.mount
      2.215s snap-gnome\x2dlogs-31.mount
      2.180s snap-gtk\x2dcommon\x2dthemes-319.mount
      2.167s snap-discord-66.mount
      2.165s snap-libreoffice-65.mount
      2.158s snap-gnome\x2dlogs-34.mount
      2.148s snap-gnome\x2d3\x2d26\x2d1604-64.mount
      2.116s snap-htop-224.mount
      2.097s snap-gnome\x2dsystem\x2dmonitor-51.mount
      2.059s snap-mailspring-239.mount
      2.055s snap-canonical\x2dlivepatch-41.mount
      2.049s snap-gimp-40.mount
      2.030s snap-htop-191.mount
      1.915s dev-mapper-ubuntu\x2d\x2dvg\x2droot.device
      1.880s bolt.service
      1.847s snap-gnome\x2dcalculator-178.mount
      1.816s snap-chromium-367.mount
      1.790s snap-gnome\x2dsystem\x2dmonitor-41.mount
      1.491s snap-gnome\x2dcalculator-175.mount
      1.435s plymouth-start.service
       354ms snapd.service
       312ms systemd-journal-flush.service
       298ms systemd-logind.service
       225ms dev-loop2.device
       221ms networkd-dispatcher.service
       218ms systemd-modules-load.service
       218ms dev-loop5.device
       217ms dev-loop8.device
       214ms dev-loop3.device
       206ms dev-loop4.device
       205ms dev-loop10.device
       199ms dev-loop1.device

I then tried to disable plymouth-quit-wait.service and fwupd.service using the command: systemctl disable name.service

I then proceeded to reboot my computer but it made no difference and when I typed system-analyze blame again they were still there.

Any suggestions or information that could help me understand services better would be greatly appreciated.

1 Answer 1


I wouldn't entirely trust that number that systemd-analyze blame is providing to you. The daemon is likely idle (see https://github.com/hughsie/fwupd/issues/442)

It's potentially caused by specifically the thunderbolt and thunderbolt-power plugins which the kernel and systemd interaction.

You can confirm this by adjusting the fwupd plugin blacklist to blacklist the thunderbolt power plugin in /etc/fwupd/daemon.conf (and potentially thunderbolt)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .