3

By default, Wekan uses :8080 (the same port is used by, for instance, Syncthing). When changing this port according to the wiki instructions:

snap set wekan port='3001'

systemctl restart snap.wekan.wekan

...it doesn't actually work. What do I need to do to change the port to say, :8081?

I tried this locally, and even disabled my firewall to see if that would be the issue. Wekan still uses the default port.

  • 1
    Have you looked at Wekan's settings, github.com/wekan/wekan/wiki/Settings? – Lewis M Oct 4 '18 at 19:11
  • 1
    When you say it doesn't work, what do you mean. Are you trying to connect to this across the net? So, did you enable access to that port on your router and on your server firewall? – pbhj Oct 4 '18 at 21:11
  • @pbhj It doesn't work as in - it doesn't actually make Wekan use another port. I tried using it locally, although I would like to use it on the web if I could figure out how to get it assigned to a domain name or sub domain. And yes, I tried enabling access on the Firewall (I don't need to do that on the router, and I can't anyway since there's no access to it - thanks to the ISP's set up). – RolandiXor Oct 5 '18 at 3:53
  • @LewisM I think so (it's been a while since I last looked at this, but to the best of my memory, I did). I will have to try again. – RolandiXor Oct 5 '18 at 3:55
2
+450

try to set using root url of Wekan with following

sudo snap set wekan root-url="http://localhost:5001"

restart your snap of Wekan again

sudo systemctl restart snap.wekan.wekan

and check your url of Wekan

sudo snap get wekan

it will appear like

enter image description here

and sign-in your Wekan on your browser like below

enter image description here

That's works to me, Hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.