5

I have a bootable dmg image and I need to burn it to a double layer DVD (the only one I have right now).

I don't have Mac just my Ubuntu PC and I heard it's possible but searching google didn't answer my question. So would you please tell me how can I do that without damaging the file or the only DVD I have right now?

3

The easiest way to do this seems to be converting the dmg to an iso file.

Managing Disk Images on the Ubuntu wiki explains this very well for different formats including dmg.

2
  • Will this keep the image bootable ?
    – taabouzeid
    Oct 31 '10 at 16:16
  • I believe so, but I'm not 100% sure. I imagine that all settings for the CD are saved as binary in the DMG, therefore the ISO should represent exactly the same burned CD. Oct 31 '10 at 16:18
3

I know this is 4 years later, but if I was pointed here others will be too.

  1. Download *.dmg.
  2. sudo apt-get install dmg2img
  3. dmg2img *.dmg *.img
  4. brasero (make data file... burn as *.iso)
  5. gparted (select USB - unmount - make FAT32)
  6. Mount the USB device.
  7. sudo add-apt-repository ppa:gezakovacs/ppa
  8. sudo apt-get update
  9. sudo apt-get install unetbootin
  10. sudo unetbootin (select disk image,point to *iso, your usb device should be in the top level of the drop down list, and burn it)
  11. It will 'hang' in the middle and then it will install complete, so don't rush to judge and cancel while its in the middle of processing ;)
2
  • +1 for explaining how to convert *.dmg into *.img (and then *.iso). -1 for telling how to make a boot pendrive from a *.dmg instead of telling how to burn it to a disc.
    – Wolfer
    Jan 18 '14 at 11:08
  • Wont dmg2img *.dmg *.iso work? img is just an iso, so changing extension will work?
    – vs4vijay
    May 31 '17 at 18:52
1

You could try all2iso. You open a terminal and write

dmg2iso filename.dmg filename.iso
And that's all. It will be bootable, I have not tried with a .dmg file, but I've tried with other filetypes and all2iso.

1
  • 1
    The all2iso download link doesn't work, it says it's forbidden for my IP. Why? I have nver downloaded form here! Requires BeOS and their account info. Trying to fix MAC boot issue here but Can't use this one.
    – user89004
    Sep 18 '12 at 14:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.