0

Iam trying to install dovecot on godaddy vps ubuntu 16 os i have installed postfix with smart host as godaddy works with relay server to send emails

When i am installing Dovecot gives me bellow error not sure what to do researched may article but dint solve the issue

root@s50-63-165-53:/home/leadshorizon# systemctl status dovecot.service
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2018-07-20 09:10:02 MST; 3min 29s ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 13249 ExecStop=/usr/bin/doveadm stop (code=exited, status=0/SUCCESS)
  Process: 13391 ExecStart=/usr/sbin/dovecot (code=exited, status=89)
 Main PID: 12966 (code=exited, status=0/SUCCESS)

Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: Error: socket() failed: Address family not supported by protocol
Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: Error: service(pop3-login): listen(::, 110) failed: Address family not supported by protocol
Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: master: Error: socket() failed: Address family not supported by protocol
Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: Error: socket() failed: Address family not supported by protocol
Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: Error: service(imap-login): listen(::, 143) failed: Address family not supported by protocol
Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: master: Error: service(pop3-login): listen(::, 110) failed: Address family not supported by protocol
Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: master: Error: socket() failed: Address family not supported by protocol
Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: master: Error: service(imap-login): listen(::, 143) failed: Address family not supported by protocol
Jul 20 09:10:02 s50-63-165-53.secureserver.net dovecot[13391]: Fatal: Failed to start listeners
  • You need to edit the Dovecot configuration to only listen on IPv4. GoDaddy VPSes by default disable v6 entirely. – Thomas Ward Jul 20 '18 at 16:20
  • can you please help me doing it – Shaik Jul 20 '18 at 16:22
  • Not from my phone. Once i'm in front of a computer, maybe. – Thomas Ward Jul 20 '18 at 16:22
  • okey no problem actually i edited this and tested a moments ago before posting https://askubuntu.com/questions/440649/how-to-disable-ipv6-in-ubuntu-14-04 – Shaik Jul 20 '18 at 16:24
  • edited /etc/sysctl.conf net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1 – Shaik Jul 20 '18 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.