2

I just purchased a Lenovo Yoga 730 15" laptop, and installed Ubuntu 16.04 in place of Windows 10. Install seemingly worked fine, but now I have no wifi device available. Tried a reinstall just to be sure, and the same issue is happening. I don't believe it to be a hardware issue, as wifi was working without issue on Windows before I wiped it out.

When I run rfkill list I see:

0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: no

But when I run lspci I only see one item in the list claiming to be a network device:

3a:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device b822 (rev ff)

I have a USB wifi adapter and that gets me connected without issue, but obviously that is not the desired solution. Does anyone have any insight on what might be causing the issue?

Output from modinfo -p rtl8822be:

fix_rate: (int)
debug_level: (int)
swenc:Set to 1 for software crypto (default 0)
(bool)
ips:Set to 0 to not use link power save (default 1)
(bool)
swlps:Set to 1 to use SW control power save (default 0)
(bool)
fwlps:Set to 1 to use FW control power save (default 1)
(bool)
msi:Set to 1 to use MSI interrupts mode (default 1)
(bool)
dma64:Set to 1 to use DMA 64 (default 0)
(bool)
aspm:Set to 1 to enable ASPM (default 1)
(int)
debug:Set debug level (0-5) (default 0)
debug_mask:Set debug mask (default 0) (ullong)
disable_watchdog:Set to 1 to disable the watchdog (default 0)
(bool)
  • What is the kernel version uname -a? – Pilot6 Jul 20 '18 at 14:31
  • 4.13.0-45-generic #50~16.04.1-Ubuntu SMP Wed May 30 11:18:27 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux @Pilot6 – Shaun Jul 20 '18 at 14:33
  • Please edit to include results from terminal for modinfo -p rtl8822be – Jeremy31 Jul 20 '18 at 17:51
  • @Jeremy31 - Added output – Shaun Jul 21 '18 at 2:27
3

The current Ubuntu kernel doesn't support this new adapter. You need to install a driver. Connect to the Internet and run in a terminal:

sudo apt install git dkms
git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6

Now reboot and disable Secure Boot in BIOS.

If there are any errors, please tell us in comments.

  • When running sudo dkms add ./rtlwifi-new I get: Directory: /usr/src/.-rtlwifi-new does not exist. The rtlwifi directory does exist in /home – Shaun Jul 20 '18 at 15:10
  • 1
    I changed the 3rd command. It is _ instead of -. Run it now. – Pilot6 Jul 20 '18 at 15:18
  • 1
    Did you disable Secure Boot in BIOS? – Pilot6 Jul 20 '18 at 15:37
  • 1
    Well, I have no other info. This driver should work. – Pilot6 Jul 20 '18 at 15:50
  • 1
    Yes, it should be added to the mainline kernel sometime. You can ask Larry Finger, who is packaging these drivers for linux for some help. – Pilot6 Jul 20 '18 at 16:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.