11

This is the error:

Error processing remote manifest (duplicity-inc.20180712T125810Z.to.20180719T130228Z.manifest.gpg): GPG Failed, see log below:
===== Begin GnuPG log =====
gpg: WARNING: "--no-use-agent" is an obsolete option - it has no effect
gpg: AES256 encrypted data
gpg: encrypted with 1 passphrase
gpg: decryption failed: Bad session key
===== End GnuPG log =====
5
  • 1
    Has it ever worked, or is this the first time you have tried it on this PC? If running this from a script, please include script; otherwise please include the command line text used to run duplicity. Please amend the original post to include these details by clicking on edit above.
    – K7AAY
    Jul 19 '18 at 16:10
  • Are you backing up? Restoring? Jul 19 '18 at 16:36
  • Has worked fine. I did do an update yesterday, but notes didn't mention backup util.
    – C. Davis
    Jul 19 '18 at 18:33
  • I didn't run duplicity from the command line, Backup does.
    – C. Davis
    Jul 19 '18 at 18:34
  • Try this restore by hand. I have had the same problem. Aug 29 '18 at 18:47
4

The author of Deja Dup has published https://wiki.gnome.org/Apps/DejaDup/PassphraseProblems2019 in which he describes possible reasons due to bugs in earlier versions of Deja Dup and bugs in the underlying duplicity.

TL;DR is that you might have entered a wrong password when being prompted. Unfortunately at least earlier versions of duplicity don't check if the passed passphrase equals the one used in past backups.

In my case the most recent backup files were encrypted with a wrong passphrase. Said document provides a command to check that. Thus, I simply deleted those and ran backup again.

Ubuntu 18.04 uses Deja Dup version 37.0 which still contains this bug. According to the document linked above, the bug is fixed as of 39.1.

1
  • Can I upgrade to 39.1 on Ubuntu 18.04? apt-get install --only-upgrade tells me that it's 'already the newest version'
    – mcExchange
    Jun 24 at 10:39
3

probably a to gpg 2.1 upgrade issue as explained here

https://answers.launchpad.net/duplicity/+question/289102
and here
https://answers.launchpad.net/duplicity/+question/288602
with a workaround mentioned here
https://superuser.com/questions/984977/duplicity-restore-failing-no-secret-key

..ede/duply.net

1
  • This solution works for me, but I find it doesn't take effect until I either restart my machine or delete my backups and re-create them (thus re-setting the encryption password).
    – Sam
    Oct 23 '18 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.