0

I am using ubuntu 18.04 with kernel 4.17.0-041700rc6 on my ASUS FX503-VD laptop with Intel Core i5-7300hq and NVIDIA GTX 1050 (4GB).

I had several issues with this laptop since installing Ubuntu up to touchpad fix. Upgrading to 17rc6 kernel fixed the issue with touchpad. After installing nvidia drivers, i figured out that my battery drains out very fast (i installed TLP but it's still 3-4 hours).

So i tried to switch back to intel card and that freezes my system after login.

I tried to follow steps in https://askubuntu.com/a/923216/847770 and successfully created an image. When i was trying to boot with this image in grub, it pops kernel panic (seems as i am doing the wrong thing), but i had to give it a try, because i have no 10-linux file.

Here's ls -a /boot output:

.                                    initrd.img-4.18.0-041800rc5-generic
..                                   memtest86+.bin
abi-4.15.0-20-generic                memtest86+.elf
abi-4.15.0-23-generic                memtest86+_multiboot.bin
abi-4.17.0-041700rc6-generic         retpoline-4.15.0-20-generic
abi-4.17.8-041708-generic            retpoline-4.15.0-23-generic
abi-4.18.0-041800rc5-generic         retpoline-4.17.0-041700rc6-generic
acpi_gpufix                          retpoline-4.17.8-041708-generic
config-4.15.0-20-generic             retpoline-4.18.0-041800rc5-generic
config-4.15.0-23-generic             System.map-4.15.0-20-generic
config-4.17.0-041700rc6-generic      System.map-4.15.0-23-generic
config-4.17.8-041708-generic         System.map-4.17.0-041700rc6-generic
config-4.18.0-041800rc5-generic      System.map-4.17.8-041708-generic
efi                                  System.map-4.18.0-041800rc5-generic
grub                                 vmlinuz-4.15.0-20-generic
initrd.img-4.15.0-20-generic         vmlinuz-4.15.0-23-generic
initrd.img-4.15.0-23-generic         vmlinuz-4.17.0-041700rc6-generic
initrd.img-4.17.0-041700rc6-generic  vmlinuz-4.17.8-041708-generic
initrd.img-4.17.8-041708-generic     vmlinuz-4.18.0-041800rc5-generic

As you can see i successfully copied it to /boot.

Also here's my ls -a /etc/grub.d/ output:.

.                40_custom_proxy  45_uefi-firmware  proxifiedScripts
..               41_linux_proxy   46_custom_proxy   README
00_header        42_linux_xen     47_custom         .script_sources.txt
05_debian_theme  43_memtest86+    backup
10_linux_proxy   44_os-prober     bin

Here's nvidia-smi output:

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 396.24.10              Driver Version: 396.24.10                 |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1050    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   50C    P3    N/A /  N/A |    320MiB /  4042MiB |      1%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1163      G   /usr/lib/xorg/Xorg                            28MiB |
|    0      1576      G   /usr/bin/gnome-shell                          48MiB |
|    0      1753      G   /usr/lib/xorg/Xorg                           127MiB |t 
|    0      1927      G   /usr/bin/gnome-shell                         115MiB |
+-----------------------------------------------------------------------------+

I hope that Glat (https://askubuntu.com/users/680254/glats) can see my post and help me with the issue.

EDIT 2

Actually I've found out that it boots with acpi=off option, but it turns off the tauchpad, so its not a fix for me. However, battery still drains really fast and in addition i dont know how to change my keyboard backlight, (no such file in /sys/class/leds as kbd:backlight etc.)

EDIT 3

Yesterday I tried installing Linux Mint, as I saw one post on the internet, where a guy has the same laptop (asus fx503vd) and he made prime-select work by switching to MDM desktop manager, but gksu was deleted, and i had no luck switching back to it. Still looking for an answer.

EDIT 4

This ***** question becomes a horrible blog. Just found a page with possible solution https://connorkuehl.github.io/dell-inspiron-7559-linux-guide/index.html , so i might be trying installing bumblebee, as it can help to fully turn off my nvidia card so i can save power.

EDIT 5

I finally made it to the point with working touchpad AND nvidia drivers. SO before installing bumblebee i am going to make a restore img. Things getting better!

-1

So, I made it work on Ubuntu 18.04 lts by following this guide (https://askubuntu.com/a/923216/847770)

WARNING Ubuntu 16.04 is not competible with this guide because of libssl 1.1 is not supported, which makes iASL work bad.

Also you will have to install bumblebee and blacklist your drivers in it's .conf file.

Now I can switch my cards with any freezes :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.