1

I get a problem with my Transmission 2.94 on Ubuntu 16.04 LTS server. I used this guide to install Transmission.

  • I tried different dir on my disks and all give me same problem.
  • I tried reinstall and that didn't help.
  • I tried to edit sudo nano /etc/transmission-daemon/settings.json with no help and working on user groups.

On this cmd is this correct?

sudo usermod -a -G debian-transmission myuser

Now I don’t know what to do.

problem indicator

I did edit the path after the picture was taken.

Permission denied (/home/thomas/media/hdd2/ubuntu-16.04.4-server-amd64.iso)

still same problem

When connected to SMB and download with utorrent on windows to Ubuntu path it is successful.

edit:

thomas@ubuntu:~$ command ls -ld /home/thomas/media/hdd2{,/ubuntu-16.04.4-server-amd64.iso}
ls: cannot access '/home/thomas/media/hdd2/ubuntu-16.04.4-server-amd64.iso': No such file or directory
drwxrwsr-x 4 thomas thomas 4096 Jul 18 18:20 /home/thomas/media/hdd2
thomas@ubuntu:~$

Edit:

i did tried to edit /etc/init.d/transmission-daemon and set the user to "root" this also gives me error

  • Could you please edit your question to include the output of command ls -ld /home/thomas/media/hdd2{,/ubuntu-16.04.4-server-amd64.iso}? Thanks. – David Foerster Jul 19 '18 at 16:05
  • In case this is a mountpoint: `/home/thomas/media/hdd2/: You can't use a windows partition for this. – Rinzwind Jul 20 '18 at 8:16
0

The cmd you wrote is gonna add your user to the debian-transmission group. That's correct. However, you need to log out and log back to apply this setting, maybe that's where it went wrong.

Maybe there's a simple folder permission. If it's what I think, here's what you need to do:

(EDIT: new directories)

  • change group ownership of the download folder:

    $ sudo chgrp -R debian-transmission /media/hdd2/tv

  • grant write access for group members:

    $ sudo chmod -R 770 /media/hdd2/tv

  • In settings.json, change the path of the download folder:

    "download-dir": "/media/hdd2/tv",

  • Restart the deamon:

    $ sudo service transmission-daemon stop

    $ sudo service transmission-daemon start

  • every time i change something i usergroups i do a reboot just to be sure – thomas Jul 19 '18 at 17:47
  • the problem did come back after i did delete the download and tried again so it was a 2min fix – thomas Jul 19 '18 at 18:04
  • Is there a temporary download folder like download-incomplete? What is the output of the following command: ls -l /home/thomas/media/hdd2/. Maybe also add the settings.json file to your original post, there might me something wrong here. – ChuckMaurice Jul 20 '18 at 7:18
  • now i did change the folder to /media/hdd2/tv hoping that would change someting but no luck. – thomas Jul 20 '18 at 8:03
  • settings.json shows that "download-dir": "/media". Set this value to the correct path. – ChuckMaurice Jul 20 '18 at 8:09
0
{
"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "0.0.0.0",
"bind-address-ipv6": "::",
"blocklist-enabled": false,
"blocklist-url": "http://www.example.com/blocklist",
"cache-size-mb": 4,
"dht-enabled": true,
"download-dir": "/media",
"download-limit": 100,
"download-limit-enabled": 0,
"download-queue-enabled": true,
"download-queue-size": 5,
"encryption": 1,
"idle-seeding-limit": 30,
"idle-seeding-limit-enabled": false,
"incomplete-dir": "/var/lib/transmission-daemon/Downloads",
"incomplete-dir-enabled": false,
"lpd-enabled": false,
"max-peers-global": 200,
"message-level": 1,
"peer-congestion-algorithm": "",
"peer-id-ttl-hours": 6,
"peer-limit-global": 200,
"peer-limit-per-torrent": 50,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": "default",
"pex-enabled": true,
"port-forwarding-enabled": false,
"preallocation": 1,
"prefetch-enabled": true,
"queue-stalled-enabled": true,
"queue-stalled-minutes": 30,
"ratio-limit": 2,
"ratio-limit-enabled": false,
"rename-partial-files": true,
"rpc-authentication-required": true,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-host-whitelist": "",
"rpc-host-whitelist-enabled": true,
"rpc-password": "{018b0d1476c793d3b8a88Vppg",
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": "thomas",
"rpc-whitelist": "127.0.0.1,192.168.*.*",
"rpc-whitelist-enabled": true,
"scrape-paused-torrents-enabled": true,
"script-torrent-done-enabled": false,
"script-torrent-done-filename": "",
"seed-queue-enabled": false,
"seed-queue-size": 10,
"speed-limit-down": 100,
"speed-limit-down-enabled": false,
"speed-limit-up": 100,
"speed-limit-up-enabled": false,
"start-added-torrents": true,
"trash-original-torrent-files": false,
"umask": 2,
"upload-limit": 100,
"upload-limit-enabled": 0,
"upload-slots-per-torrent": 14,
"utp-enabled": true

}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.