1

I've been trying to set up Ruby on Rails for Ubuntu 11.10 following these instructions, but I can't get it to work.

I'll follow the install guide all the way up to "rvm install ruby-1.9.2", and at that point terminal will configure ruby-1.9.2, compile it, and as it starts installing it my computer will shut down. Not freeze up or become unresponsive, but totally shut down.

What might be causing this error, and how might I fix it? Thanks!

  • Does it shutdown gracefully (go through all the usual shutdown sequence) or just turn right off abruptly? If the former, that's very weird, if the latter I'd suspect hardware. – Caesium Feb 22 '12 at 4:06
1

I don't think compiling would directly be causing a reboot but it may be a side effect of your system having to do a lot of work. The CPU could be overheating. I'd keep an eye on the temperatures especially if you're overclocking.

  • Thanks, yeah that seemed to be the problem. A new computer is in order... – Phaedrus Raznikov Jun 29 '12 at 18:02
0

I had the same problem. After reviewing

rvm requirements

I found a suggestion that I needed to install ruby 1.8.7 before I tried to install a 1.9 ruby, so I tried that, and it worked perfectly. Make sure you've got all the other requirements installed too.

0

Can you paste your output when you run

    RVM Requirements

Also please check out the documentation at guides.rubyonrails.org.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.