6

I want to disable the audible terminal bell, and enable the visual terminal bell. I followed the instructions from this answer

$ gsettings get org.gnome.desktop.wm.preferences audible-bell
false

$ gsettings get org.gnome.desktop.wm.preferences visual-bell
true

$ gsettings get org.gnome.desktop.wm.preferences visual-bell-type
'frame-flash'

but I am getting both the audible and visual bells. Likewise, disabling the terminal bell under "Sound" in preferences disables both types.

Ideas?

3

Apparently, the sound is coming from Ubuntu's alert system. In Ubuntu 18.04, you need to go Setting > Sound > Sound Effects > Alert Volume > Off.

I got this answer from: Turn off error sound on Ubuntu 18.04

| improve this answer | |
1

A work-around until you find the perfect solution is to replace the bell sound with no sound. On my system the alert sound is found in:

/usr/share/sounds/ubuntu/stereo/bell.ogg

To confirm it is the same sound you hear, use:

paplay /usr/share/sounds/ubuntu/stereo/bell.ogg

Then from this answer: How to disable Alert volume from the command line?, try this:

sudo mv -v /usr/share/sounds/ubuntu/stereo/*.ogg {*.disabled}

Note this disables all sounds. For just bell.ogg use

sudo mv -v /usr/share/sounds/ubuntu/stereo/bell.ogg bell.ogg.disabled
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.