8

I've bought a new Seagate Expansion Portable Drive 2TB with exFat format. It works normally on Windows. On Ubuntu 18.04 I tried to mount the HD but failed.

I found advice to install exfat-fuse and exfat-utils (exfat 1.2.8). I've done that and still the HD is not mounting.

I tried to format the hd to NTFS but failed. I formatted it back with success to exFat. Still Ubuntu does not mount the HD. On disk it just mention 2TB block device. No partition.

Tried to format using mkfs.exfat but I get an Input/Output error. Checking on Windows for drive error found nothing wrong.

12

Just press Ctrl+Alt+t and When your terminal appears, Type below command and boom:

sudo apt-get install exfat-fuse exfat-utils

Unplug your exFat external flash and then plug it again. This way settled my issue. Hope helps you.

| improve this answer | |
  • 1
    already tried. See comment above. – starplateena Oct 24 '18 at 0:38
0

exfat* was missing from my list as well, and I couldn't find a reliable repo source to add:

# apt-get install ex
example-content exim4 exim4-base exim4-config exim4-daemon-heavy  exim4-daemon-light exim4-dev exim4-doc-html exuberant-ctags

I ended up downloading it from here.

Then ran dpkg -i exfat-fuse_1.2.8-1_amd64.deb to install.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.