1

I have Ubuntu 18.04 installed with Gnome Desktop. My keyboard numerical keyboard is not working even after installing numlockx and checking that is showing ON from Dconf[enter image description here]

1

Make sure to check that the numlock state is showing as 'on'

You can do this by pressing Ctrl+Alt+T and then running:

gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state

There should be a return 'on'

If it is not, then run:

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

Check again and confirm that it is showing as 'on'.

Also make sure to log out and log back in or just do a full reboot to make sure that gnome has taken the new settings.

1

Can you try to enable the numlock from terminal code is

setxkbmap -option keypad:pointerkeys

The second solution is in Gnome we must go to System -> Parameters -> Keyboard, then find the section "Mouse buttons" and disable the emulation of mouse from the keyboard.

0

I'm not sure about the dconf GUI method but, you can open a terminal with Ctrl+Alt+T and try:

gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

I don't have a problem with my numlock so I'm not sure how to duplicate your situation.

0

go to settings keyboard and make sure your model keyboard is correct. Mine was not, when I changed it to the correct model my number keys work just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.